aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-bootsplash/gpe-bootsplash_1.13.bb')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.13.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
index e69de29bb2..bcf50ae7d2 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
@@ -0,0 +1,19 @@
+inherit gpe
+
+DEPENDS = "gtk+ librsvg"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI += "file://splash-p.svg file://splash-l.svg"
+
+FILES_${PN} += "${datadir}/gpe"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ mv ${D}/${sysconfdir}/rcS.d/S00bootsplash ${D}/${sysconfdir}/rcS.d/S02bootsplash
+}
+