aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch')
-rw-r--r--packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch185
1 files changed, 0 insertions, 185 deletions
diff --git a/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch b/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch
deleted file mode 100644
index 6ef5ddca91..0000000000
--- a/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch
+++ /dev/null
@@ -1,185 +0,0 @@
-diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/Makefile gpe-today-0.08/Makefile
---- ../gpe-today-0.08-r0.orig/gpe-today-0.08/Makefile 2003-11-27 20:25:07.000000000 +0000
-+++ gpe-today-0.08/Makefile 2004-06-22 04:30:22.722392968 +0000
-@@ -1,32 +1,20 @@
- PACKAGE = gpe-today
- PREFIX = /usr/local
--VERSION = 0.08
-+DEBUG = no
- CVSBUILD = no
--#DEBUG = yes
--#EFENCE = yes
--LINGUAS = pt de zh_TW ga ro wa fr sv nl cs sk ru
--
--MEMBERS = main todo calendar date xsettings
--
--GTKCFLAGS = `pkg-config --cflags gtk+-2.0`
--GTKLDFLAGS += `pkg-config --libs gtk+-2.0`
--
--CPPFLAGS = -I../libgpewidget -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -D_GNU_SOURCE
-+VERSION = 0.08
-
--ifeq ($(EFENCE),yes)
--LDFLAGS = -lefence
--endif
-+LINGUAS = pt de zh_TW ga ro wa fr sv nl cs sk ru
-
--ifeq ($(DEBUG),yes)
--CFLAGS = -g
--else
--CFLAGS = -Os -fomit-frame-pointer
-+ifeq ($(CVSBUILD),yes)
-+PACKAGE_CPPFLAGS += -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -I../libdisplaymigration -I../libgpepimc
-+PACKAGE_LDFLAGS += -L../libeventdb -L../libtododb -L../libxsettings-client -Wl,-rpath-link,../libxsettings -L../libgpepimc
- endif
-+PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS)
-+PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS)
-+PACKAGE_LDFLAGS += $(STANDARD_LDFLAGS) $(GPELIBS) -leventdb -ltododb -lXsettings-client -ldisplaymigration -lsqlite -lgpepimc
-
--CFLAGS += -Wall $(GTKCFLAGS)
--LDFLAGS += $(GTKLDFLAGS) -L/usr/local/lib -L../libeventdb -leventdb -L../libtododb -ltododb -L../libxsettings -L../libxsettings-client -lXsettings-client -Wl,-rpath-link,../libxsettings
--CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
--#CFLAGS += -MD
-+MEMBERS = main todo calendar date xsettings
-
- .SUFFIXES: .d
-
-@@ -42,10 +30,10 @@
- BUILD = build
- endif
-
--all: $(PACKAGE) all-mo
-+all: $(PACKAGE)
-
- $(PACKAGE): $(OBJS)
-- $(CC) -o $@ $^ -L../libgpewidget -lgpewidget -lsqlite $(LDFLAGS)
-+ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
-
- install-program: all $(PACKAGE).desktop
- for i in $(PIXMAPS); do install -D -m 644 pixmaps/$$i $(DESTDIR)$(PREFIX)/share/$(PACKAGE)/pixmaps/$$i; done
-diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.dpkg_ipkg gpe-today-0.08/build/Makefile.dpkg_ipkg
---- ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.dpkg_ipkg 2003-11-27 20:25:07.000000000 +0000
-+++ gpe-today-0.08/build/Makefile.dpkg_ipkg 2004-06-22 04:20:51.000000000 +0000
-@@ -18,8 +18,10 @@
- LIBGPEWIDGET_PC = libgpewidget
- endif
-
-+ifeq ($(IN_LIBGPEWIDGET),)
- GPECFLAGS = $(shell $(PC_EXTRA) pkg-config --cflags $(LIBGPEWIDGET_PC))
- GPELIBS = $(shell $(PC_EXTRA) pkg-config --libs $(LIBGPEWIDGET_PC))
-+endif
-
- GTKCFLAGS = $(shell pkg-config --cflags gtk+-2.0)
- GTKLIBS = $(shell pkg-config --libs gtk+-2.0)
-@@ -28,16 +30,16 @@
- STANDARD_CFLAGS = -MD -Wall
-
- ifeq ($(DEBUG),yes)
--STANDARD_CFLAGS += -O2 -g
--STANDARD_LDFLAGS = -g
-+CFLAGS += -O2 -g
-+LDFLAGS = -g
- else
--STANDARD_CFLAGS += -Os -fomit-frame-pointer
-+CFLAGS += -Os -fomit-frame-pointer
- endif
-
- dist: check-source clean dist-prep
- rm -rf ../$(PACKAGE)-$(VERSION)
- mkdir ../$(PACKAGE)-$(VERSION)
-- ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.d" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
-+ ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
- ( cd ../$(PACKAGE)-$(VERSION); mkdir build; cp $(BUILD)/Makefile.dpkg_ipkg $(BUILD)/Makefile.translation build/ ; sed 's:^CVSBUILD.*:CVSBUILD = no:' < Makefile > Makefile.new; mv Makefile.new Makefile )
- ( cd .. ; tar cf - $(PACKAGE)-$(VERSION) | gzip -9 >$(PACKAGE)-$(VERSION).tar.gz )
- rm -rf ../$(PACKAGE)-$(VERSION)
-@@ -53,8 +55,13 @@
-
- install: install-program install-mo
-
-+clean-dist:
-+ rm -rf familiar/dist familiar/dist.list
-+
-+clean: clean-dist
-+
- check-source:
-- @if ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
-+ @if [ -e familiar ] && ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
-
- ipkg: check-source ipkg-prep clean
- rm -rf familiar/dist
-@@ -68,9 +75,9 @@
- $(MAKE) DESTDIR=`pwd`/familiar/dist PREFIX=/usr prefix=/usr DEBUG=no install-program
- rm -rf familiar/dist.list
- ipkg-build -o 0 -g 0 familiar/dist | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> familiar/dist.list
-- rm -f
- if [ "x$(LINGUAS)" != "x" ]; then make translation-ipkg; tr ' ' '\n' < translation-ipkgs.txt >> familiar/dist.list; fi
- md5sum `cat familiar/dist.list` > $(PACKAGE)_$(VERSION).batch
-+ rm -rf familiar/dist familiar/dist.list
- $(MAKE) printinfo
-
- dpkg: dist
-@@ -89,6 +96,7 @@
- @printf " ftp://ftp.handhelds.org/pub/projects/gpe/\n"
- @printf " (handhelds.org:~ftp/pub/projects/gpe/source)\n"
- @printf "You can use 'make dist-upload' to do that.\n"
-+ @printf "You are currently known as USER %s.\n" $(USER)
- @printf '-------------------------------------------------------------------------------\n'
-
- tag: check-source
-@@ -101,3 +109,6 @@
-
- %.pc: %.pc.in
- sed 's:PREFIX:$(PREFIX):;s:BUILDDIR:$(shell pwd):;s:VERSION:$(VERSION):' < $< > $@
-+
-+.c.o:;
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(PACKAGE_CFLAGS) $(PACKAGE_CPPFLAGS) -c $< -o $@
-diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.translation gpe-today-0.08/build/Makefile.translation
---- ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.translation 2003-11-27 20:25:07.000000000 +0000
-+++ gpe-today-0.08/build/Makefile.translation 2004-06-22 04:20:51.000000000 +0000
-@@ -5,7 +5,7 @@
- # use ipkg-build or ipkg-deb-build
- IPKG_BUILD := ipkg-build
-
--TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint/
-+TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint
-
- ifeq ($(DIR_PO),)
- DIR_PO := po
-@@ -56,7 +56,7 @@
- ( SOURCES="$(SOURCES)"; for DESK in $(PACKAGE).desktop.in $(EXTRA_DESKTOPS); do if [ -f $$DESK ]; then intltool-extract --type=gettext/ini $$DESK; SOURCES="$$SOURCES $${DESK}.h"; fi; done; if [ "x$$SOURCES" != "x" ]; then xgettext --add-comments=TRANSLATORS: -k_ -kN_ -o $(DIR_PO)/$(PACKAGE).pot.new $$SOURCES; fi )
- if [ -f $(DIR_PO)/$(PACKAGE).pot.new ]; then if cmp -s $(DIR_PO)/$(PACKAGE).pot.new $(PACKAGE).pot; then rm $(DIR_PO)/$(PACKAGE).pot.new; else mv $(DIR_PO)/$(PACKAGE).pot.new $(DIR_PO)/$(PACKAGE).pot; fi; fi
-
--clean: clean-po
-+clean: clean-po clean-dist-translation
-
- clean-po:
- rm -rf $(DIR_PO)/*.mo
-@@ -76,10 +76,17 @@
-
- MAINTAINER = $(shell grep 'Maintainer: ' familiar/$(CONTROL) | cut -d ' ' -f 2-)
-
-+ifndef BUILD
-+BUILD = ../build
-+endif
-+
- transdist := familiar/dist-translation
--templates := ../build/familiar
-+templates := $(BUILD)/familiar
- ipkglist := translation-ipkgs.txt
-
-+clean-dist-translation:
-+ rm -rf $(transdist) $(ipkglist)
-+
- real-translation-package: all-mo
- rm -rf $(transdist) $(ipkglist)
- for LINGUA in $(LINGUAS); do \
-@@ -89,8 +96,7 @@
- install -m 644 po/$$LINGUA.mo $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES/$(PACKAGE).mo; \
- sed -e "s/<maintainer>/$(MAINTAINER)/;s/<package>/$(BINPACKAGE)/;s/<version>/$(VERSION)/;s/<language>/$$i/;s!<source>!$(SOURCE)!" $(templates)/control.translation > $(transdist)/$$i/CONTROL/control; \
- install $(templates)/postinst.translation $(transdist)/$$i/CONTROL/postinst; \
-- chown -R root.root $(transdist)/$$i; \
-- $(IPKG_BUILD) $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
-+ $(IPKG_BUILD) -g 0 -o 0 $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
- done
-
- translation-ipkg: