aboutsummaryrefslogtreecommitdiffstats
path: root/packages/icewm/icewm_1.2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/icewm/icewm_1.2.20.bb')
-rw-r--r--packages/icewm/icewm_1.2.20.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/icewm/icewm_1.2.20.bb b/packages/icewm/icewm_1.2.20.bb
index e69de29bb2..3d6eba69f0 100644
--- a/packages/icewm/icewm_1.2.20.bb
+++ b/packages/icewm/icewm_1.2.20.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/wm"
+DESCRIPTION = "IceWM Window Manager"
+LICENSE = "GPL"
+DEPENDS = "x11 xext xcomposite libxfixes xdamage libxrender xinerama xpm xrandr xft"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/icewm/icewm-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/icewm-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
+
+pkg_postinst() {
+update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/icewm-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager /usr/bin/icewm-session
+} \ No newline at end of file