aboutsummaryrefslogtreecommitdiffstats
path: root/packages/jpeg/jpeg_6b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/jpeg/jpeg_6b.bb')
-rw-r--r--packages/jpeg/jpeg_6b.bb18
1 files changed, 14 insertions, 4 deletions
diff --git a/packages/jpeg/jpeg_6b.bb b/packages/jpeg/jpeg_6b.bb
index 277cdfa48c..23e3ed82be 100644
--- a/packages/jpeg/jpeg_6b.bb
+++ b/packages/jpeg/jpeg_6b.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
SECTION = "libs"
PRIORITY = "required"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
@@ -10,8 +10,7 @@ LICENSE ="jpeg"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian.patch;patch=1 \
file://ldflags.patch;patch=1 \
- file://paths.patch;patch=1 \
- file://install.patch;patch=1"
+ file://paths.patch;patch=1"
S = "${WORKDIR}/jpeg-${PV}"
inherit autotools
@@ -22,5 +21,16 @@ EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR}/${HOST_SYS}-libtool"'
CFLAGS_append = " -D_REENTRANT"
do_stage() {
- autotools_stage_all
+ install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
+ install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
+ install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
+ install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
+ install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
+ oe_libinstall -so libjpeg ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${includedir} \
+ ${D}${mandir}/man1 ${D}${libdir}
+ oe_runmake 'DESTDIR=${D}' install
}