aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kexecboot/initramfs_kexecboot_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/kexecboot/initramfs_kexecboot_1.0.bb')
-rw-r--r--packages/kexecboot/initramfs_kexecboot_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/kexecboot/initramfs_kexecboot_1.0.bb b/packages/kexecboot/initramfs_kexecboot_1.0.bb
new file mode 100644
index 0000000000..e1337419b8
--- /dev/null
+++ b/packages/kexecboot/initramfs_kexecboot_1.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
+PR = "r6"
+RDEPENDS = "kexecboot"
+do_compile() {
+ cat > init.sh << EOF
+#!/bin/sh
+/bin/mount -t proc proc /proc
+/usr/bin/kexecboot -a 270 -i /dev/event0
+EOF
+}
+
+do_install() {
+ install -m 0755 ${S}/init.sh ${D}/init
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/init /proc /mnt"