aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb')
-rw-r--r--packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb b/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
index 695df70c12..0588ff40ba 100644
--- a/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
+++ b/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
@@ -21,11 +21,16 @@ COMPATIBLE_HOST = "arm.*-linux"
FILES_kernel = "/boot /tmp"
DEPENDS = "modutils-cross virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}"
+# Don't want kernel zImage in rootfs, put it into /tmp ramdisk
+FILES_kernel = ""
+ALLOW_EMPTY_kernel = "1"
+FILES_kernel-image += "/tmp/zImage"
+
do_configure_prepend() {
install -m 0644 ${S}/arch/arm/def-configs/${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
}
-pkg_postinst_kernel () {
+pkg_postinst_kernel-image () {
test -f /tmp/zImage || exit 0
cp /tmp/zImage /dev/mtdblock/1
rm /tmp/zImage
@@ -33,6 +38,9 @@ sync
cat /dev/mtdblock/1 >/dev/null
}
+pkg_postinst_kernel () {
+}
+
pkg_postinst_modules () {
if [ -n "$D" ]; then
${HOST_PREFIX}depmod -A -b $D -F $D/boot/System.map-${PV} ${KERNEL_VERSION}