aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openzaurus_2.6.13-mm1.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/packages/linux/linux-openzaurus_2.6.13-mm1.bb b/packages/linux/linux-openzaurus_2.6.13-mm1.bb
index e3c1a69da4..076c0f9a2b 100644
--- a/packages/linux/linux-openzaurus_2.6.13-mm1.bb
+++ b/packages/linux/linux-openzaurus_2.6.13-mm1.bb
@@ -180,15 +180,19 @@ do_configure() {
yes '' | oe_runmake oldconfig
}
-# Check the kernel is below the 1272*1024 byte limit for the c7x0
+# Check the kernel is below the 1272*1024 byte limit for the PXA Zaurii
do_compile_append() {
- if [ "${MACHINE}" == "c7x0" ]; then
- size=`ls arch/${ARCH}/boot/${KERNEL_IMAGETYPE} -s | cut -d ' ' -f 1`
- if [ $size -ge 1271 ]; then
- rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
- die "This kernel is too big for the c7x0 and will destroy your machine if you flash it!!!"
- fi
- fi
+ case ${MACHINE} in
+ c7x0 | akita | poodle | spitz | borzoi )
+ size=`ls arch/${ARCH}/boot/${KERNEL_IMAGETYPE} -s | cut -d ' ' -f 1`
+ if [ $size -ge 1271 ]; then
+ rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+ die "This kernel is too big for the c7x0 and will destroy your machine if you flash it!!!"
+ fi
+ ;;
+ *)
+ ;;
+ esac
}
do_deploy() {