aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mc/mc_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mc/mc_4.6.1.bb')
-rw-r--r--packages/mc/mc_4.6.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/mc/mc_4.6.1.bb b/packages/mc/mc_4.6.1.bb
new file mode 100644
index 0000000000..58a8fdf51b
--- /dev/null
+++ b/packages/mc/mc_4.6.1.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU Midnight Commander is a file \
+manager for free operating systems."
+HOMEPAGE = "http://www.ibiblio.org/mc/"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+PRIORITY = "optional"
+DEPENDS = "ncurses glib-2.0"
+RDEPENDS = "ncurses-terminfo"
+PR ="r1"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
+--without-nfs --without-gpm-mouse --with-screen=ncurses"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_install() {
+ cd src
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../syntax
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../po
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../vfs
+ oe_runmake 'DESTDIR=${D}' install
+ cd ..
+
+ install -m 0644 lib/cedit.menu ${D}${datadir}/mc/
+ install -m 0644 lib/edit.indent.rc ${D}${datadir}/mc/
+ install -m 0644 lib/edit.spell.rc ${D}${datadir}/mc/
+ install -m 0644 lib/mc.charsets ${D}${datadir}/mc/
+ install -m 0644 lib/mc.ext ${D}${datadir}/mc/
+ install -m 0644 lib/mc.lib ${D}${datadir}/mc/
+ install -m 0644 lib/mc.menu ${D}${datadir}/mc/
+ install -m 0644 lib/mc.menu.sr ${D}${datadir}/mc/
+}