aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla/firefox_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mozilla/firefox_1.0.3.bb')
-rw-r--r--packages/mozilla/firefox_1.0.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_1.0.3.bb b/packages/mozilla/firefox_1.0.3.bb
index e69de29bb2..b3eeedcf64 100644
--- a/packages/mozilla/firefox_1.0.3.bb
+++ b/packages/mozilla/firefox_1.0.3.bb
@@ -0,0 +1,18 @@
+PR = "r0"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://firefox-cc-fix.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+
+inherit mozilla
+
+include firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+}
+