aboutsummaryrefslogtreecommitdiffstats
path: root/packages/php/php_5.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/php/php_5.1.4.bb')
-rw-r--r--packages/php/php_5.1.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/php/php_5.1.4.bb b/packages/php/php_5.1.4.bb
new file mode 100644
index 0000000000..fc982a678c
--- /dev/null
+++ b/packages/php/php_5.1.4.bb
@@ -0,0 +1,38 @@
+SECTION = "console/network"
+DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
+MAINTAINER = "Shane Volpe <shanevolpe@gmail.com>"
+LICENSE = "PHP"
+DEPENDS = "zlib libxml2 mysql libiconv"
+SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/php-${PV}"
+PR = "r1"
+
+inherit autotools
+
+export THREADS="pthread"
+export LIBS=" -lpthread "
+
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+EXTRA_OECONF = "--without-iconv \
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-memory-limit \
+ --enable-wddx \
+ --with-zlib"
+
+EXTRA_OECONF += " --without-pear"
+# Uncomment the following two lines, and comment the above to enable PEAR
+#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR}/php"
+#DEPENDS += " php-native"
+
+acpaths = ""
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
+ find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+}
+
+do_install () {
+ oe_runmake 'INSTALL_ROOT=${D}' install
+}