aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pth
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pth')
-rw-r--r--packages/pth/pth_2.0.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/pth/pth_2.0.2.bb b/packages/pth/pth_2.0.2.bb
index e69de29bb2..14621818da 100644
--- a/packages/pth/pth_2.0.2.bb
+++ b/packages/pth/pth_2.0.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}