aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python/python-pygame_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python/python-pygame_1.7.1.bb')
-rw-r--r--packages/python/python-pygame_1.7.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-pygame_1.7.1.bb b/packages/python/python-pygame_1.7.1.bb
new file mode 100644
index 0000000000..d80359dbba
--- /dev/null
+++ b/packages/python/python-pygame_1.7.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python libSDL Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "LGPL"
+RDEPENDS = "python-core python-numeric libsdl-x11"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
+SRCNAME = "pygame"
+PR = "ml1"
+
+SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz \
+ file://Setup"
+S = "${WORKDIR}/${SRCNAME}-${PV}release"
+
+inherit distutils
+
+do_configure_prepend() {
+ SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >Setup
+ cat ${WORKDIR}/Setup >>Setup
+}