aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpe-games/icebloxx_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/qpe-games/icebloxx_1.0.0.bb')
-rw-r--r--packages/qpe-games/icebloxx_1.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/qpe-games/icebloxx_1.0.0.bb b/packages/qpe-games/icebloxx_1.0.0.bb
index e69de29bb2..e1a842375a 100644
--- a/packages/qpe-games/icebloxx_1.0.0.bb
+++ b/packages/qpe-games/icebloxx_1.0.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "IceBloxx"
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+AUTHOR = "Robert Ernst"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-IceBloxx.html"
+
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/icebloxx_V1.0.0.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://icebloxx.patch;patch=1"
+
+PV = "1.0.0"
+S = "${WORKDIR}/icebloxx_V${PV}"
+
+APPNAME = "icebloxx"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_compile_prepend() {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie