aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sgml-common/sgml-common_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sgml-common/sgml-common_0.6.3.bb')
-rw-r--r--packages/sgml-common/sgml-common_0.6.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/sgml-common/sgml-common_0.6.3.bb b/packages/sgml-common/sgml-common_0.6.3.bb
index 8b9fd5aeda..3454b1cb01 100644
--- a/packages/sgml-common/sgml-common_0.6.3.bb
+++ b/packages/sgml-common/sgml-common_0.6.3.bb
@@ -14,3 +14,29 @@ SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-co
file://autohell.patch;patch=1"
inherit autotools
+
+do_compile_append() {
+ # install-catalog script contains hardcoded reference to /etc/sgml.
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/install-catalog
+}
+
+pkg_postinst() {
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-ent.cat \
+ ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/sgml-ent.cat
+}
+
+pkg_postrm() {
+ install-catalog \
+ --remove ${sysconfdir}/sgml/sgml-ent.cat \
+ ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog \
+ --remove ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/sgml-ent.cat
+}
+