aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tor/tor_0.1.1.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/tor/tor_0.1.1.26.bb')
-rw-r--r--packages/tor/tor_0.1.1.26.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/tor/tor_0.1.1.26.bb b/packages/tor/tor_0.1.1.26.bb
new file mode 100644
index 0000000000..751182aadb
--- /dev/null
+++ b/packages/tor/tor_0.1.1.26.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Tor is a network of virtual tunnels that allows people and groups \
+ to improve their privacy and security on the Internet."
+SECTION = "console/network"
+PRIORITY = "optional"
+HOMEPAGE = "http://tor.eff.org"
+LICENSE = "BSD"
+PR="r0"
+DEPENDS = "libevent openssl zlib"
+
+SRC_URI = "http://tor.eff.org/dist/${P}.tar.gz \
+ file://configure.patch;patch=1;pnum=1 \
+ file://make.patch;patch=1;pnum=1 \
+ file://compat.patch;patch=1;pnum=1 \
+ file://tor.init"
+
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "tor"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install ${WORKDIR}/tor.init ${D}${sysconfdir}/init.d/tor
+}