aboutsummaryrefslogtreecommitdiffstats
path: root/packages/totem/totem_0.99.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/totem/totem_0.99.15.bb')
-rw-r--r--packages/totem/totem_0.99.15.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/totem/totem_0.99.15.bb b/packages/totem/totem_0.99.15.bb
index e69de29bb2..aaf956917f 100644
--- a/packages/totem/totem_0.99.15.bb
+++ b/packages/totem/totem_0.99.15.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+LICENSE="GPL"
+
+SRC_URI="http://www.hadess.net/files/software/totem/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine libgnomeui"
+RDEPENDS += " libgnomeui"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}