aboutsummaryrefslogtreecommitdiffstats
path: root/packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch')
-rw-r--r--packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch b/packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch
new file mode 100644
index 0000000000..89555ac027
--- /dev/null
+++ b/packages/u-boot/u-boot-1.1.4/u-boot-make381-fix.patch
@@ -0,0 +1,15 @@
+--- /examples/orig-Makefile 2005-12-16 18:39:27.000000000 +0200
++++ /examples/Makefile 2006-12-02 14:58:59.000000000 +0200
+@@ -123,10 +123,10 @@
+ $(LD) -g $(EX_LDFLAGS) -Ttext $(LOAD_ADDR) \
+ -o $@ -e $(<:.o=) $< $(LIB) \
+ -L$(gcclibdir) -lgcc
+-%.srec: %
++%.srec: %.o
+ $(OBJCOPY) -O srec $< $@ 2>/dev/null
+
+-%.bin: %
++%.bin: %.o
+ $(OBJCOPY) -O binary $< $@ 2>/dev/null
+
+ #########################################################################