aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xfce
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xfce')
-rw-r--r--packages/xfce/libxfce4util.inc26
-rw-r--r--packages/xfce/libxfce4util_4.4.1.bb23
2 files changed, 22 insertions, 27 deletions
diff --git a/packages/xfce/libxfce4util.inc b/packages/xfce/libxfce4util.inc
deleted file mode 100644
index ee7b886f20..0000000000
--- a/packages/xfce/libxfce4util.inc
+++ /dev/null
@@ -1,26 +0,0 @@
-# libxfce4util OE build file
-# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see COPYING.MIT)
-
-DESCRIPTION = "Basic utility library for Xfce4"
-SECTION = "x11/libs"
-LICENSE = "GPL"
-DEPENDS = "glib-2.0 xfce4-dev-tools"
-
-inherit xfce
-
-MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
-
-do_stage() {
- install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
- # The line below expands to the list of headers that native makefile
- # would install. Complain and/or fix if it's not portable enough
- for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
- install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
- done
-
- oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
-
-}
-
-FILES_${PN}-dev += " ${datadir}/xfce4/m4"
diff --git a/packages/xfce/libxfce4util_4.4.1.bb b/packages/xfce/libxfce4util_4.4.1.bb
index a53a83e861..3c33b2f929 100644
--- a/packages/xfce/libxfce4util_4.4.1.bb
+++ b/packages/xfce/libxfce4util_4.4.1.bb
@@ -2,4 +2,25 @@
# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see COPYING.MIT)
-require ${PN}.inc
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xfce4-dev-tools"
+
+inherit xfce
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
+ # The line below expands to the list of headers that native makefile
+ # would install. Complain and/or fix if it's not portable enough
+ for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"