aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch')
-rw-r--r--packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch b/packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch
new file mode 100644
index 0000000000..bbb4a60a16
--- /dev/null
+++ b/packages/xorg-xserver/xserver-kdrive-git/enable-tslib.patch
@@ -0,0 +1,26 @@
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2007-09-08 22:17:11.000000000 +0200
++++ git/configure.ac 2007-09-08 22:32:45.000000000 +0200
+@@ -1834,7 +1834,7 @@
+ AC_CHECK_LIB([rt], [nanosleep], XEPHYR_LIBS="$XEPHYR_LIBS -lrt"))
+
+ if test "x$TSLIB" = xyes; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
+ if test "x$HAVE_TSLIB" = xno; then
+ AC_MSG_ERROR([tslib must be installed to build the tslib driver. See http://tslib.berlios.de/])
+ fi
+@@ -1858,10 +1858,10 @@
+ ;;
+ esac
+ KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
+- KDRIVE_LOCAL_LIBS="$TSLIB_LIBS $DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
++ KDRIVE_LOCAL_LIBS="$DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $FB_LIB $MI_LIB $KDRIVE_PURE_LIBS"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $KDRIVE_OS_LIB $OS_LIB"
+- KDRIVE_LIBS="$KDRIVE_LOCAL_LIBS $XSERVERLIBS_LIBS"
++ KDRIVE_LIBS="$TSLIB_LIBS $KDRIVE_LOCAL_LIBS $XSERVERLIBS_LIBS"
+
+ # check if we can build Xephyr
+ PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])