aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/cherokee/cherokee-0.5.5/.mtn2git_empty0
-rw-r--r--packages/cherokee/cherokee-0.5.5/Makefile.am.patch26
-rw-r--r--packages/cherokee/cherokee-0.5.5/configure.in.patch52
-rw-r--r--packages/cherokee/cherokee-nossl_0.5.3.bb5
-rw-r--r--packages/cherokee/cherokee.inc46
-rw-r--r--packages/cherokee/cherokee_0.5.3.bb49
-rw-r--r--packages/cherokee/cherokee_0.5.5.bb6
-rw-r--r--packages/cherokee/files/cherokee.init2
-rw-r--r--packages/cherokee/site/.mtn2git_empty0
-rw-r--r--packages/cherokee/site/common2
-rw-r--r--packages/contacts/contacts_0.2.bb22
-rw-r--r--packages/dbus/dbus-1.0.1/dbus-1.init8
-rw-r--r--packages/dbus/dbus_1.0.1.bb2
-rw-r--r--packages/gnome/libbacon_cvs.bb20
-rw-r--r--packages/tinymail/files/iconv-detect.h5
-rw-r--r--packages/tinymail/files/no-iconv-detect.patch78
-rw-r--r--packages/tinymail/tinymail_svn.bb12
17 files changed, 285 insertions, 50 deletions
diff --git a/packages/cherokee/cherokee-0.5.5/.mtn2git_empty b/packages/cherokee/cherokee-0.5.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/.mtn2git_empty
diff --git a/packages/cherokee/cherokee-0.5.5/Makefile.am.patch b/packages/cherokee/cherokee-0.5.5/Makefile.am.patch
new file mode 100644
index 0000000000..168200c476
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/Makefile.am.patch
@@ -0,0 +1,26 @@
+Index: cherokee-0.5.5/cget/Makefile.am
+===================================================================
+--- cherokee-0.5.5.orig/cget/Makefile.am
++++ cherokee-0.5.5/cget/Makefile.am
+@@ -12,6 +12,8 @@ $(LARGEFILE_CFLAGS)
+
+ cget_LDADD = \
+ ../cherokee/libcherokee-client.la \
++../cherokee/libcherokee-base.la \
++../cherokee/libcherokee-server.la \
+ $(TLS_LIBS) \
+ $(PTHREAD_LIBS) \
+ $(PTHREAD_CFLAGS)
+Index: cherokee-0.5.5/cherokee/Makefile.am
+===================================================================
+--- cherokee-0.5.5.orig/cherokee/Makefile.am
++++ cherokee-0.5.5/cherokee/Makefile.am
+@@ -923,7 +923,7 @@ cherokee_logrotate_LDADD = libcherokee-b
+ noinst_PROGRAMS = cherokee_admin
+
+ cherokee_admin_SOURCES = cherokee_admin.c
+-cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la
++cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la libcherokee-server.la
+
+ ##cherokee_table_test_SOURCES = cherokee_table_test.c
+ ##cherokee_table_test_LDADD = libcherokee.la
diff --git a/packages/cherokee/cherokee-0.5.5/configure.in.patch b/packages/cherokee/cherokee-0.5.5/configure.in.patch
new file mode 100644
index 0000000000..d6b75f9f1f
--- /dev/null
+++ b/packages/cherokee/cherokee-0.5.5/configure.in.patch
@@ -0,0 +1,52 @@
+Add cache support for some values which require running on the
+target. These need to be set in the site files:
+
+ cherokee_cv_have_epoll
+ cherokee_cv_func_sendfile_works
+
+Both should be set to yes for any reasonably recent linux.
+
+Index: cherokee-0.5.5/configure.in
+===================================================================
+--- cherokee-0.5.5.orig/configure.in
++++ cherokee-0.5.5/configure.in
+@@ -280,6 +280,7 @@ have_epoll=no
+ if test "x$have_epoll_include" = "xyes"; then
+ AC_MSG_CHECKING(for epoll system call)
+
++ AC_CACHE_CHECK([for epoll],cherokee_cv_have_epoll,[
+ AC_TRY_RUN([
+ #include <stdint.h>
+ #include <sys/param.h>
+@@ -297,8 +298,7 @@ if test "x$have_epoll_include" = "xyes";
+ epfd = epoll_create(256);
+ exit (epfd == -1 ? 1 : 0);
+ }
+- ], have_epoll=yes)
+- AC_MSG_RESULT($have_epoll)
++ ], have_epoll=yes)])
+ fi
+
+ dnl
+@@ -625,16 +625,16 @@ ETR_SOCKET_NSL
+ SENDFILE_CHECK
+
+ # Is sendfile broken?
+-AC_MSG_CHECKING(if sendfile works)
++AC_CACHE_CHECK([if sendfile works],cherokee_cv_func_sendfile_works,[
+ AC_TRY_RUN([#include <errno.h>
+ int main() {
+ int o = 0;
+ if (-1 == sendfile(0, 0, &o, 0) && errno == ENOSYS) return -1;
+ return 0;
+- } ],
+- AC_MSG_RESULT(yes),
+- [ AC_MSG_RESULT(no)
+- AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile]) ])
++ } ], cherokee_cv_func_sendfile_works=yes,cherokee_cv_func_sendfile_works=no,cherokee_cv_func_sendfile_works=no)])
++if test "$cherokee_cv_func_sendfile_works" = no; then
++ AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile])
++fi
+
+ # readdir_r()
+ LIBWWW_READDIR_R_TYPE
diff --git a/packages/cherokee/cherokee-nossl_0.5.3.bb b/packages/cherokee/cherokee-nossl_0.5.3.bb
index 5487afcfde..409366004a 100644
--- a/packages/cherokee/cherokee-nossl_0.5.3.bb
+++ b/packages/cherokee/cherokee-nossl_0.5.3.bb
@@ -7,3 +7,8 @@ FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/cherokee-${PV}', '${FILE_D
S = "${WORKDIR}/cherokee-${PV}"
EXTRA_OECONF = "--disable-tls --disable-static --disable-nls"
+
+# Fix up files - the ${PN} in the defaults expand to cherokee-nossl
+# but we are actually installing into cherokee.
+FILES_${PN} += "${datadir}/cherokee ${libdir}/cherokee/*"
+FILES_${PN}-dbg += "${libdir}/cherokee/.debug"
diff --git a/packages/cherokee/cherokee.inc b/packages/cherokee/cherokee.inc
new file mode 100644
index 0000000000..9736370cb4
--- /dev/null
+++ b/packages/cherokee/cherokee.inc
@@ -0,0 +1,46 @@
+DESCRIPTION = "Cherokee Web Server fast and secure"
+DESCRIPTION_cget = "Small downloader based in the Cherokee client library"
+HOMEPAGE = "http://www.cherokee-project.com/"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "libpcre gnutls"
+
+SRC_URI = "http://www.cherokee-project.com/download/0.5/${PV}/cherokee-${PV}.tar.gz \
+ file://cherokee.init "
+
+inherit autotools pkgconfig binconfig update-rc.d
+
+EXTRA_OECONF = "--enable-tls=gnutls --disable-static --disable-nls"
+
+do_install_prepend () {
+ # It only needs this app during the install, so compile it natively
+ $BUILD_CC -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
+}
+do_install_append () {
+ install -m 0755 -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
+}
+
+# Put -dev near the front so we can move the .la files into it with a wildcard
+PACKAGES = "${PN}-dbg ${PN}-dev \
+ libcherokee-server libcherokee-client libcherokee-base \
+ cget ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${libdir}/cherokee/*.la"
+FILES_cget = "${bindir}/cget"
+FILES_libcherokee-server = "${libdir}/libcherokee-server*"
+FILES_libcherokee-client = "${libdir}/libcherokee-client*"
+FILES_libcherokee-base = "${libdir}/libcherokee-base*"
+
+CONFFILES_${PN} = "${sysconfdir}/cherokee/mime.types \
+ ${sysconfdir}/cherokee/mods-available/admin \
+ ${sysconfdir}/cherokee/mods-available/ssl \
+ ${sysconfdir}/cherokee/advanced.conf \
+ ${sysconfdir}/cherokee/cherokee.conf \
+ ${sysconfdir}/cherokee/mime.compression.types \
+ ${sysconfdir}/cherokee/sites-available/example.com \
+ ${sysconfdir}/cherokee/sites-available/default \
+ ${sysconfdir}/cherokee/icons.conf"
+
+INITSCRIPT_NAME = "cherokee"
+INITSCRIPT_PARAMS = "defaults 91 91"
diff --git a/packages/cherokee/cherokee_0.5.3.bb b/packages/cherokee/cherokee_0.5.3.bb
index 511ebc4904..c0f1396c7d 100644
--- a/packages/cherokee/cherokee_0.5.3.bb
+++ b/packages/cherokee/cherokee_0.5.3.bb
@@ -1,51 +1,14 @@
-DESCRIPTION = "Cherokee Web Server fast and secure"
-DESCRIPTION_cget = "Small downloader based in the Cherokee client library"
-HOMEPAGE = "http://www.cherokee-project.com/"
-SECTION = "network"
-LICENSE = "GPL"
-DEPENDS = "libpcre gnutls"
-PR = "r4"
+PR = "r7"
-SRC_URI = "http://www.cherokee-project.com/download/0.5/${PV}/cherokee-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://Makefile.in.patch;patch=1 \
- file://Makefile.cget.patch;patch=1 \
- file://util.patch;patch=1 \
- file://cherokee.init"
+SRC_URI_append = "file://configure.patch;patch=1 \
+ file://Makefile.in.patch;patch=1 \
+ file://Makefile.cget.patch;patch=1 \
+ file://util.patch;patch=1"
-inherit autotools pkgconfig binconfig update-rc.d
-
-EXTRA_OECONF = "--enable-tls=gnutls --disable-static --disable-nls"
+require cherokee.inc
do_configure() {
gnu-configize
oe_runconf
sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/*libtool
}
-do_install_prepend () {
- $BUILD_CC -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
-}
-do_install_append () {
- install -m 0755 -d ${D}${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
-}
-
-PACKAGES =+ "cget libcherokee-server libcherokee-client libcherokee-base"
-
-FILES_cget = "${bindir}/cget"
-FILES_libcherokee-server = "${libdir}/libcherokee-server*"
-FILES_libcherokee-client = "${libdir}/libcherokee-client*"
-FILES_libcherokee-base = "${libdir}/libcherokee-base*"
-
-CONFFILES_${PN} = "${sysconfdir}/cherokee/mime.types \
- ${sysconfdir}/cherokee/mods-available/admin \
- ${sysconfdir}/cherokee/mods-available/ssl \
- ${sysconfdir}/cherokee/advanced.conf \
- ${sysconfdir}/cherokee/cherokee.conf \
- ${sysconfdir}/cherokee/mime.compression.types \
- ${sysconfdir}/cherokee/sites-available/example.com \
- ${sysconfdir}/cherokee/sites-available/default \
- ${sysconfdir}/cherokee/icons.conf"
-
-INITSCRIPT_NAME = "cherokee"
-INITSCRIPT_PARAMS = "defaults 91 91"
diff --git a/packages/cherokee/cherokee_0.5.5.bb b/packages/cherokee/cherokee_0.5.5.bb
new file mode 100644
index 0000000000..e1fe602282
--- /dev/null
+++ b/packages/cherokee/cherokee_0.5.5.bb
@@ -0,0 +1,6 @@
+PR = "r4"
+
+SRC_URI_append = "file://configure.in.patch;patch=1 \
+ file://Makefile.am.patch;patch=1"
+
+require cherokee.inc
diff --git a/packages/cherokee/files/cherokee.init b/packages/cherokee/files/cherokee.init
index 0ea0fd3a99..ea1263aff5 100644
--- a/packages/cherokee/files/cherokee.init
+++ b/packages/cherokee/files/cherokee.init
@@ -12,7 +12,7 @@ test ! -r "$CONFIG" && exit 0
case "$1" in
start)
echo "Starting $DESC: "
- start-stop-daemon --oknodo -S -x $DAEMON -- -b
+ start-stop-daemon --oknodo -S -x $DAEMON -- -b -C $CONFIG
;;
stop)
diff --git a/packages/cherokee/site/.mtn2git_empty b/packages/cherokee/site/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cherokee/site/.mtn2git_empty
diff --git a/packages/cherokee/site/common b/packages/cherokee/site/common
new file mode 100644
index 0000000000..f7ad462caa
--- /dev/null
+++ b/packages/cherokee/site/common
@@ -0,0 +1,2 @@
+cherokee_cv_have_epoll=yes
+cherokee_cv_func_sendfile_works=yes
diff --git a/packages/contacts/contacts_0.2.bb b/packages/contacts/contacts_0.2.bb
new file mode 100644
index 0000000000..071c827709
--- /dev/null
+++ b/packages/contacts/contacts_0.2.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade libbacon eds-dbus"
+DESCRIPTION = "Contacts is an address-book application."
+PR = "r0"
+
+SRC_URI = "http://projects.o-hand.com/sources/contacts/contacts-0.2.tar.gz \
+ file://stock_contact.png \
+ file://stock_person.png"
+
+inherit autotools pkgconfig
+
+
+do_install_append () {
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
+}
+
+FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
+ ${datadir}/pixmaps/stock_person.png"
+
diff --git a/packages/dbus/dbus-1.0.1/dbus-1.init b/packages/dbus/dbus-1.0.1/dbus-1.init
index 4829c0d4a8..38e7574ad5 100644
--- a/packages/dbus/dbus-1.0.1/dbus-1.init
+++ b/packages/dbus/dbus-1.0.1/dbus-1.init
@@ -10,6 +10,7 @@ NAME=dbus
DAEMONUSER=messagebus
PIDDIR=/var/run/dbus
PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
DESC="system message bus"
EVENTDIR=/etc/dbus-1/event.d
@@ -40,8 +41,15 @@ start_it_up()
rm -f $PIDFILE
fi
fi
+
+ if [ ! -d $UUIDDIR ]; then
+ mkdir -p $UUIDDIR
+ chown $DAEMONUSER $UUIDDIR
+ chgrp $DAEMONUSER $UUIDDIR
+ fi
dbus-uuidgen --ensure
+
echo -n "Starting $DESC: "
start-stop-daemon --start --quiet --pidfile $PIDFILE \
--user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
diff --git a/packages/dbus/dbus_1.0.1.bb b/packages/dbus/dbus_1.0.1.bb
index 688e5c630f..49112f3ee4 100644
--- a/packages/dbus/dbus_1.0.1.bb
+++ b/packages/dbus/dbus_1.0.1.bb
@@ -6,6 +6,8 @@ DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl"
+PR = "r1"
+
SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://tmpdir.patch;patch=1 \
file://dbus-1.init \
diff --git a/packages/gnome/libbacon_cvs.bb b/packages/gnome/libbacon_cvs.bb
new file mode 100644
index 0000000000..cbe1a9ad47
--- /dev/null
+++ b/packages/gnome/libbacon_cvs.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Bacon is a multimedia library"
+LICENSE = "GPLv2"
+
+DEPENDS = "glib-2.0"
+
+PV = "0.0+cvs${SRCDATE}"
+
+inherit gnome
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=${PN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+
diff --git a/packages/tinymail/files/iconv-detect.h b/packages/tinymail/files/iconv-detect.h
new file mode 100644
index 0000000000..46f476d5bc
--- /dev/null
+++ b/packages/tinymail/files/iconv-detect.h
@@ -0,0 +1,5 @@
+/* This is an auto-generated header, DO NOT EDIT! */
+
+#define ICONV_ISO_D_FORMAT "iso-%d-%d"
+#define ICONV_ISO_S_FORMAT "iso-%d-%s"
+#define ICONV_10646 "iso-10646"
diff --git a/packages/tinymail/files/no-iconv-detect.patch b/packages/tinymail/files/no-iconv-detect.patch
new file mode 100644
index 0000000000..558cbb2f93
--- /dev/null
+++ b/packages/tinymail/files/no-iconv-detect.patch
@@ -0,0 +1,78 @@
+--- /tmp/ticonv.m4 2006-11-19 12:01:18.000000000 +0100
++++ trunk/m4/ticonv.m4 2006-11-19 12:14:50.378554000 +0100
+@@ -14,12 +14,7 @@
+ save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $ICONV_CFLAGS"
+ LIBS="$LIBS $ICONV_LIBS -liconv"
+-AC_CACHE_CHECK(for iconv in -liconv, ac_cv_libiconv, AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+-#include <iconv.h>
+-]], [[
+- iconv_t cd;
+- cd = iconv_open ("UTF-8", "ISO-8859-1");
+-]])],[ac_cv_libiconv=yes],[ac_cv_libiconv=no]))
++
+ if test $ac_cv_libiconv = yes; then
+ ICONV_LIBS="$ICONV_LIBS -liconv"
+ have_iconv=yes
+@@ -33,39 +28,6 @@
+ if test $ac_cv_libiconv = no; then
+ AC_CHECK_FUNCS(gnu_get_libc_version)
+ fi
+- AC_CACHE_CHECK([if iconv() handles UTF-8], ac_cv_libiconv_utf8, AC_RUN_IFELSE([AC_LANG_SOURCE([[
+-#include <iconv.h>
+-#include <stdlib.h>
+-#include <string.h>
+-#ifdef HAVE_GNU_GET_LIBC_VERSION
+-#include <gnu/libc-version.h>
+-#endif
+-
+-int main (int argc, char **argv)
+-{
+- const char *from = "Some Text \xA4";
+- const char *utf8 = "Some Text \xC2\xA4";
+- char *transbuf = malloc (20), *trans = transbuf;
+- iconv_t cd;
+- size_t from_len = strlen (from), utf8_len = 20;
+- size_t utf8_real_len = strlen (utf8);
+-
+-#ifdef HAVE_GNU_GET_LIBC_VERSION
+- /* glibc 2.1.2's iconv is broken in hard to test ways. */
+- if (!strcmp (gnu_get_libc_version (), "2.1.2"))
+- exit (1);
+-#endif
+-
+- cd = iconv_open ("UTF-8", "ISO-8859-1");
+- if (cd == (iconv_t) -1)
+- exit (1);
+- if (iconv (cd, &from, &from_len, &trans, &utf8_len) == -1 || from_len != 0)
+- exit (1);
+- if (memcmp (utf8, transbuf, utf8_real_len) != 0)
+- exit (1);
+-
+- exit (0);
+-}]])],[ac_cv_libiconv_utf8=yes],[ac_cv_libiconv_utf8=no; have_iconv=no],[ac_cv_libiconv_utf8=no; have_iconv=no]))
+ fi
+
+ if test "$have_iconv" = no; then
+@@ -73,20 +35,5 @@
+ fi
+ AC_SUBST(ICONV_CFLAGS)
+ AC_SUBST(ICONV_LIBS)
+-
+-CFLAGS="$CFLAGS -I$srcdir"
+-
+-AC_MSG_CHECKING(preferred charset formats for system iconv)
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[
+-#define CONFIGURE_IN
+-#include "iconv-detect.c"
+-]])],[
+- AC_MSG_RESULT(found)
+-],[
+- AC_MSG_RESULT(not found)
+-],[])
+-
+-CFLAGS="$save_CFLAGS"
+-LIBS="$save_LIBS"
+-
+ ])
++
diff --git a/packages/tinymail/tinymail_svn.bb b/packages/tinymail/tinymail_svn.bb
index cc889489ac..416aa0f4e3 100644
--- a/packages/tinymail/tinymail_svn.bb
+++ b/packages/tinymail/tinymail_svn.bb
@@ -1,16 +1,17 @@
SECTION = "x11/utils"
-DEPENDS = "gtk+ glib-2.0 gnome-vfs-dbus libgnomeui eds-dbus libiconv"
+DEPENDS = "gtk+ glib-2.0 gnome-vfs-dbus gconf-dbus libgnomeui eds-dbus"
DESCRIPTION = "TinyMail is an attempt to create an E-mail framework for mobile devices"
LICENSE = "GPL"
PV = "0.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF=" --disable-gnome --with-platform=gpe --with-html-component=none"
-#camel-lite-configure-hack.patch is still needed after the maxdate, but needs fixing
SRC_URI = "svn://svn.tinymail.org/svn/tinymail/;module=trunk;proto=http \
file://camel-lite-configure-hack.patch;patch=1;maxdate=20061113 \
+ file://no-iconv-detect.patch;patch=1;mindate=20061114 \
+ file://iconv-detect.h \
file://gtk-doc.m4 \
file://gtk-doc.make"
@@ -21,6 +22,8 @@ do_configure_prepend() {
mkdir -p m4
install ${WORKDIR}/gtk-doc.m4 ./m4/
install ${WORKDIR}/gtk-doc.make ./
+
+ cp ${WORKDIR}/iconv-detect.h ${S}/libtinymail-camel/camel-lite/
}
@@ -50,7 +53,4 @@ FILES_tinymail-camel-lite-dev += "${libdir}/libcamel-lite*.so \
${libdir}/camel-lite-1.2/camel-providers/*.a "
FILES_tinymail-camel-lite-dbg += "${libdir}/camel-lite-1.2/camel-providers/.debug"
-PARALLEL_MAKE = ""
-LDFLAGS += "-liconv"
-