aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rwxr-xr-xpackages/initscripts/initscripts-1.0/checkroot.sh14
-rw-r--r--packages/initscripts/initscripts_1.0.bb2
2 files changed, 10 insertions, 6 deletions
diff --git a/packages/initscripts/initscripts-1.0/checkroot.sh b/packages/initscripts/initscripts-1.0/checkroot.sh
index df3035371b..44db23707e 100755
--- a/packages/initscripts/initscripts-1.0/checkroot.sh
+++ b/packages/initscripts/initscripts-1.0/checkroot.sh
@@ -148,7 +148,10 @@ else
# 2 or larger. A return code of 1 indicates that filesystem
# errors were corrected but that the boot may proceed.
#
- if test "$?" -gt 1
+
+ echo "RETURNCODE: [$RTC]"
+
+ if test "$RTC" -gt 3
then
# Since this script is run very early in the boot-process, it should be safe to assume that the
@@ -159,13 +162,14 @@ else
# Surprise! Re-directing from a HERE document (as in
# "cat << EOF") won't work, because the root is read-only.
echo
- echo "fsck failed. Please repair manually and reboot. Please note"
- echo "that the root filesystem is currently mounted read-only. To"
- echo "remount it read-write:"
+ echo "fsck failed. Please repair manually and reboot. "
+ echo "Please note that the root filesystem is currently "
+ echo "mounted read-only. To remount it read-write:"
echo
echo " # mount -n -o remount,rw /"
echo
- echo "CONTROL-D will exit from this shell and REBOOT the system."
+ echo "CONTROL-D will exit from this shell"
+ echo "and REBOOT the system."
echo
# Start a single user shell on the console
/sbin/sulogin $CONSOLE
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index 306629732a..39662eb31a 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -5,7 +5,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "makedevs virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r82"
+PR = "r83"
SRC_URI = "file://halt \
file://ramdisk \