aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/opie-bartender/opie-bartender_1.1.8.bb22
-rw-r--r--packages/opie-parashoot/opie-parashoot_1.1.8.bb25
-rw-r--r--packages/opie-parashoot/opie-parashoot_cvs.bb2
-rw-r--r--packages/qte/qte-2.3.9-snapshot/opie-freetype.patch0
-rw-r--r--packages/qte/qte-2.3.9-snapshot/qt-visibility.patch11
-rw-r--r--packages/qte/qte_2.3.9-snapshot.bb1
6 files changed, 60 insertions, 1 deletions
diff --git a/packages/opie-bartender/opie-bartender_1.1.8.bb b/packages/opie-bartender/opie-bartender_1.1.8.bb
index e69de29bb2..e91b6d0a80 100644
--- a/packages/opie-bartender/opie-bartender_1.1.8.bb
+++ b/packages/opie-bartender/opie-bartender_1.1.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Bartender drink receipe database"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+APPNAME = "bartender"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/apps/opie-bartender \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+
+S = "${WORKDIR}/opie-bartender"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -d ${D}${palmtopdir}/etc/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 db/drinkdb.txt ${D}${palmtopdir}/etc/${APPNAME}/
+}
diff --git a/packages/opie-parashoot/opie-parashoot_1.1.8.bb b/packages/opie-parashoot/opie-parashoot_1.1.8.bb
index e69de29bb2..497d2d9823 100644
--- a/packages/opie-parashoot/opie-parashoot_1.1.8.bb
+++ b/packages/opie-parashoot/opie-parashoot_1.1.8.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Game: shoot the parachutists"
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+PR = "r1"
+
+APPNAME = "parashoot"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/games/parashoot \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/application/libparashoot.so* bin/parashoot apps/Games/parashoot.desktop pics/parashoot
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.xpm ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/packages/opie-parashoot/opie-parashoot_cvs.bb b/packages/opie-parashoot/opie-parashoot_cvs.bb
index 9759d316cf..c049285d6d 100644
--- a/packages/opie-parashoot/opie-parashoot_cvs.bb
+++ b/packages/opie-parashoot/opie-parashoot_cvs.bb
@@ -4,6 +4,7 @@ PRIORITY = "optional"
MAINTAINER = "Team Opie <opie@handhelds.org>"
LICENSE = "GPL"
PV = "1.1.8+cvs-${CVSDATE}"
+PR = "r1"
APPNAME = "parashoot"
SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/games/parashoot \
@@ -18,5 +19,6 @@ inherit opie
do_install() {
install -d ${D}${palmtopdir}/pics/${APPNAME}/
install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.xpm ${D}${palmtopdir}/pics/${APPNAME}/
}
diff --git a/packages/qte/qte-2.3.9-snapshot/opie-freetype.patch b/packages/qte/qte-2.3.9-snapshot/opie-freetype.patch
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/qte/qte-2.3.9-snapshot/opie-freetype.patch
+++ /dev/null
diff --git a/packages/qte/qte-2.3.9-snapshot/qt-visibility.patch b/packages/qte/qte-2.3.9-snapshot/qt-visibility.patch
index 780d400316..449b5ae9ca 100644
--- a/packages/qte/qte-2.3.9-snapshot/qt-visibility.patch
+++ b/packages/qte/qte-2.3.9-snapshot/qt-visibility.patch
@@ -447,3 +447,14 @@
int space, int spacer )
{
typedef int fixed;
+--- qt-2.3.9-snapshot-20041229/src/kernel/qfontmanager_qws.h~qt-visibility.patch
++++ qt-2.3.9-snapshot-20041229/src/kernel/qfontmanager_qws.h
+@@ -84,7 +84,7 @@
+ // e.g. Truetype Times, 10 point. There's only one of these though;
+ // we want to share generated glyphs
+
+-class QRenderedFont {
++class Q_EXPORT QRenderedFont {
+
+ public:
+
diff --git a/packages/qte/qte_2.3.9-snapshot.bb b/packages/qte/qte_2.3.9-snapshot.bb
index e023a9fdb6..c44ca05ae6 100644
--- a/packages/qte/qte_2.3.9-snapshot.bb
+++ b/packages/qte/qte_2.3.9-snapshot.bb
@@ -17,7 +17,6 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/snapshots/qt-embedded-${PV}.tar.gz \
file://encoding.patch;patch=1 \
file://fix-qgfxraster.patch;patch=1 \
file://qt-visibility.patch;patch=1 \
- file://opie-freetype.patch;patch=1 \
file://update-qtfontdir \
file://sharp_char.h \
file://switches.h "