aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/gpe-aerial/files/iconlist.patch10
-rw-r--r--packages/gpe-clock/gpe-clock_0.25.bb9
-rw-r--r--packages/gpe-plucker/gpe-plucker_0.4.bb9
-rw-r--r--packages/gpe-session-scripts/gpe-session-scripts_0.67.bb29
-rw-r--r--packages/gpe-today/files/no-transparency.patch10
-rw-r--r--packages/gpe-today/gpe-today-0.08/.mtn2git_empty0
-rw-r--r--packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch185
-rw-r--r--packages/gpe-today/gpe-today-0.09/.mtn2git_empty0
-rw-r--r--packages/gpe-today/gpe-today-0.09/makefile.patch65
-rw-r--r--packages/gpe-today/gpe-today_0.08.bb9
-rw-r--r--packages/gpe-today/gpe-today_0.09.bb9
-rw-r--r--packages/libgpewidget/libgpewidget_0.112.bb30
-rw-r--r--packages/xserver-common/xserver-common-1.8/hx4700.patch10
13 files changed, 375 insertions, 0 deletions
diff --git a/packages/gpe-aerial/files/iconlist.patch b/packages/gpe-aerial/files/iconlist.patch
new file mode 100644
index 0000000000..004e317b90
--- /dev/null
+++ b/packages/gpe-aerial/files/iconlist.patch
@@ -0,0 +1,10 @@
+--- main.c.orig 2006-05-10 21:37:32.000000000 +0200
++++ main.c 2006-05-10 21:37:43.000000000 +0200
+@@ -33,7 +33,6 @@
+ #include <gpe/init.h>
+ #include <gpe/pixmaps.h>
+ #include <gpe/errorbox.h>
+-#include <gpe/gpe-iconlist.h>
+ #include <gpe/tray.h>
+ #include <gpe/popup.h>
+ #include <gpe/spacing.h>
diff --git a/packages/gpe-clock/gpe-clock_0.25.bb b/packages/gpe-clock/gpe-clock_0.25.bb
new file mode 100644
index 0000000000..51b001208b
--- /dev/null
+++ b/packages/gpe-clock/gpe-clock_0.25.bb
@@ -0,0 +1,9 @@
+inherit gpe
+
+DESCRIPTION = "GPE panel clock"
+DEPENDS = "gtk+ libschedule libgpewidget gpe-announce atd libgpelaunch"
+RDEPENDS = "gpe-announce atd"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
diff --git a/packages/gpe-plucker/gpe-plucker_0.4.bb b/packages/gpe-plucker/gpe-plucker_0.4.bb
new file mode 100644
index 0000000000..68acf59071
--- /dev/null
+++ b/packages/gpe-plucker/gpe-plucker_0.4.bb
@@ -0,0 +1,9 @@
+inherit gpe pkgconfig
+LICENSE = "GPL"
+DESCRIPTION = "Plucker ebook reader"
+DEPENDS = "gtk+ libgpewidget"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+PARALLEL_MAKE=""
+
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
new file mode 100644
index 0000000000..c207802f9b
--- /dev/null
+++ b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
@@ -0,0 +1,29 @@
+LICENSE = "GPL"
+
+inherit gpe
+
+DESCRIPTION = "GPE session startup scripts"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+RDEPENDS_${PN} = "matchbox matchbox-panel (>= 0.9.2-r12) matchbox-desktop (>= 0.9.1-r1) matchbox-common (>= 0.9.1-r2) gpe-session-starter gpe-bluetooth xstroke xtscal gpe-question gpe-clock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo xserver-common"
+# more rdepends: keylaunch ipaq-sleep apmd blueprobe
+DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question matchbox-applet-inputmanager gpe-clock xrandr xmodmap xdpyinfo xserver-common"
+
+SRC_URI += "file://matchbox-session \
+ file://disable-composite.xsettings"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
+ echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
+ fi
+ install -d ${D}${sysconfdir}/matchbox
+ install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
+
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+}
+
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/packages/gpe-today/files/no-transparency.patch b/packages/gpe-today/files/no-transparency.patch
new file mode 100644
index 0000000000..e10e8cd283
--- /dev/null
+++ b/packages/gpe-today/files/no-transparency.patch
@@ -0,0 +1,10 @@
+--- gpe-today-0.11/main.c.orig 2006-05-21 18:59:40.000000000 +0200
++++ gpe-today-0.11/main.c 2006-05-21 19:01:15.000000000 +0200
+@@ -85,6 +85,7 @@
+ /* some code adpated from mbdesktop.c copyright matthew allum */
+ void set_background(const char *spec)
+ {
++ return;
+ /* img-tiled:<filename>
+ * img-streched:<filename> -- will be tiled too
+ * col-solid:<filename>
diff --git a/packages/gpe-today/gpe-today-0.08/.mtn2git_empty b/packages/gpe-today/gpe-today-0.08/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-today/gpe-today-0.08/.mtn2git_empty
diff --git a/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch b/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch
new file mode 100644
index 0000000000..6ef5ddca91
--- /dev/null
+++ b/packages/gpe-today/gpe-today-0.08/gpe-today_makefiles.patch
@@ -0,0 +1,185 @@
+diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/Makefile gpe-today-0.08/Makefile
+--- ../gpe-today-0.08-r0.orig/gpe-today-0.08/Makefile 2003-11-27 20:25:07.000000000 +0000
++++ gpe-today-0.08/Makefile 2004-06-22 04:30:22.722392968 +0000
+@@ -1,32 +1,20 @@
+ PACKAGE = gpe-today
+ PREFIX = /usr/local
+-VERSION = 0.08
++DEBUG = no
+ CVSBUILD = no
+-#DEBUG = yes
+-#EFENCE = yes
+-LINGUAS = pt de zh_TW ga ro wa fr sv nl cs sk ru
+-
+-MEMBERS = main todo calendar date xsettings
+-
+-GTKCFLAGS = `pkg-config --cflags gtk+-2.0`
+-GTKLDFLAGS += `pkg-config --libs gtk+-2.0`
+-
+-CPPFLAGS = -I../libgpewidget -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -D_GNU_SOURCE
++VERSION = 0.08
+
+-ifeq ($(EFENCE),yes)
+-LDFLAGS = -lefence
+-endif
++LINGUAS = pt de zh_TW ga ro wa fr sv nl cs sk ru
+
+-ifeq ($(DEBUG),yes)
+-CFLAGS = -g
+-else
+-CFLAGS = -Os -fomit-frame-pointer
++ifeq ($(CVSBUILD),yes)
++PACKAGE_CPPFLAGS += -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -I../libdisplaymigration -I../libgpepimc
++PACKAGE_LDFLAGS += -L../libeventdb -L../libtododb -L../libxsettings-client -Wl,-rpath-link,../libxsettings -L../libgpepimc
+ endif
++PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS)
++PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS)
++PACKAGE_LDFLAGS += $(STANDARD_LDFLAGS) $(GPELIBS) -leventdb -ltododb -lXsettings-client -ldisplaymigration -lsqlite -lgpepimc
+
+-CFLAGS += -Wall $(GTKCFLAGS)
+-LDFLAGS += $(GTKLDFLAGS) -L/usr/local/lib -L../libeventdb -leventdb -L../libtododb -ltododb -L../libxsettings -L../libxsettings-client -lXsettings-client -Wl,-rpath-link,../libxsettings
+-CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+-#CFLAGS += -MD
++MEMBERS = main todo calendar date xsettings
+
+ .SUFFIXES: .d
+
+@@ -42,10 +30,10 @@
+ BUILD = build
+ endif
+
+-all: $(PACKAGE) all-mo
++all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) -o $@ $^ -L../libgpewidget -lgpewidget -lsqlite $(LDFLAGS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all $(PACKAGE).desktop
+ for i in $(PIXMAPS); do install -D -m 644 pixmaps/$$i $(DESTDIR)$(PREFIX)/share/$(PACKAGE)/pixmaps/$$i; done
+diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.dpkg_ipkg gpe-today-0.08/build/Makefile.dpkg_ipkg
+--- ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.dpkg_ipkg 2003-11-27 20:25:07.000000000 +0000
++++ gpe-today-0.08/build/Makefile.dpkg_ipkg 2004-06-22 04:20:51.000000000 +0000
+@@ -18,8 +18,10 @@
+ LIBGPEWIDGET_PC = libgpewidget
+ endif
+
++ifeq ($(IN_LIBGPEWIDGET),)
+ GPECFLAGS = $(shell $(PC_EXTRA) pkg-config --cflags $(LIBGPEWIDGET_PC))
+ GPELIBS = $(shell $(PC_EXTRA) pkg-config --libs $(LIBGPEWIDGET_PC))
++endif
+
+ GTKCFLAGS = $(shell pkg-config --cflags gtk+-2.0)
+ GTKLIBS = $(shell pkg-config --libs gtk+-2.0)
+@@ -28,16 +30,16 @@
+ STANDARD_CFLAGS = -MD -Wall
+
+ ifeq ($(DEBUG),yes)
+-STANDARD_CFLAGS += -O2 -g
+-STANDARD_LDFLAGS = -g
++CFLAGS += -O2 -g
++LDFLAGS = -g
+ else
+-STANDARD_CFLAGS += -Os -fomit-frame-pointer
++CFLAGS += -Os -fomit-frame-pointer
+ endif
+
+ dist: check-source clean dist-prep
+ rm -rf ../$(PACKAGE)-$(VERSION)
+ mkdir ../$(PACKAGE)-$(VERSION)
+- ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.d" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
++ ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
+ ( cd ../$(PACKAGE)-$(VERSION); mkdir build; cp $(BUILD)/Makefile.dpkg_ipkg $(BUILD)/Makefile.translation build/ ; sed 's:^CVSBUILD.*:CVSBUILD = no:' < Makefile > Makefile.new; mv Makefile.new Makefile )
+ ( cd .. ; tar cf - $(PACKAGE)-$(VERSION) | gzip -9 >$(PACKAGE)-$(VERSION).tar.gz )
+ rm -rf ../$(PACKAGE)-$(VERSION)
+@@ -53,8 +55,13 @@
+
+ install: install-program install-mo
+
++clean-dist:
++ rm -rf familiar/dist familiar/dist.list
++
++clean: clean-dist
++
+ check-source:
+- @if ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
++ @if [ -e familiar ] && ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
+
+ ipkg: check-source ipkg-prep clean
+ rm -rf familiar/dist
+@@ -68,9 +75,9 @@
+ $(MAKE) DESTDIR=`pwd`/familiar/dist PREFIX=/usr prefix=/usr DEBUG=no install-program
+ rm -rf familiar/dist.list
+ ipkg-build -o 0 -g 0 familiar/dist | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> familiar/dist.list
+- rm -f
+ if [ "x$(LINGUAS)" != "x" ]; then make translation-ipkg; tr ' ' '\n' < translation-ipkgs.txt >> familiar/dist.list; fi
+ md5sum `cat familiar/dist.list` > $(PACKAGE)_$(VERSION).batch
++ rm -rf familiar/dist familiar/dist.list
+ $(MAKE) printinfo
+
+ dpkg: dist
+@@ -89,6 +96,7 @@
+ @printf " ftp://ftp.handhelds.org/pub/projects/gpe/\n"
+ @printf " (handhelds.org:~ftp/pub/projects/gpe/source)\n"
+ @printf "You can use 'make dist-upload' to do that.\n"
++ @printf "You are currently known as USER %s.\n" $(USER)
+ @printf '-------------------------------------------------------------------------------\n'
+
+ tag: check-source
+@@ -101,3 +109,6 @@
+
+ %.pc: %.pc.in
+ sed 's:PREFIX:$(PREFIX):;s:BUILDDIR:$(shell pwd):;s:VERSION:$(VERSION):' < $< > $@
++
++.c.o:;
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(PACKAGE_CFLAGS) $(PACKAGE_CPPFLAGS) -c $< -o $@
+diff -urNd ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.translation gpe-today-0.08/build/Makefile.translation
+--- ../gpe-today-0.08-r0.orig/gpe-today-0.08/build/Makefile.translation 2003-11-27 20:25:07.000000000 +0000
++++ gpe-today-0.08/build/Makefile.translation 2004-06-22 04:20:51.000000000 +0000
+@@ -5,7 +5,7 @@
+ # use ipkg-build or ipkg-deb-build
+ IPKG_BUILD := ipkg-build
+
+-TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint/
++TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint
+
+ ifeq ($(DIR_PO),)
+ DIR_PO := po
+@@ -56,7 +56,7 @@
+ ( SOURCES="$(SOURCES)"; for DESK in $(PACKAGE).desktop.in $(EXTRA_DESKTOPS); do if [ -f $$DESK ]; then intltool-extract --type=gettext/ini $$DESK; SOURCES="$$SOURCES $${DESK}.h"; fi; done; if [ "x$$SOURCES" != "x" ]; then xgettext --add-comments=TRANSLATORS: -k_ -kN_ -o $(DIR_PO)/$(PACKAGE).pot.new $$SOURCES; fi )
+ if [ -f $(DIR_PO)/$(PACKAGE).pot.new ]; then if cmp -s $(DIR_PO)/$(PACKAGE).pot.new $(PACKAGE).pot; then rm $(DIR_PO)/$(PACKAGE).pot.new; else mv $(DIR_PO)/$(PACKAGE).pot.new $(DIR_PO)/$(PACKAGE).pot; fi; fi
+
+-clean: clean-po
++clean: clean-po clean-dist-translation
+
+ clean-po:
+ rm -rf $(DIR_PO)/*.mo
+@@ -76,10 +76,17 @@
+
+ MAINTAINER = $(shell grep 'Maintainer: ' familiar/$(CONTROL) | cut -d ' ' -f 2-)
+
++ifndef BUILD
++BUILD = ../build
++endif
++
+ transdist := familiar/dist-translation
+-templates := ../build/familiar
++templates := $(BUILD)/familiar
+ ipkglist := translation-ipkgs.txt
+
++clean-dist-translation:
++ rm -rf $(transdist) $(ipkglist)
++
+ real-translation-package: all-mo
+ rm -rf $(transdist) $(ipkglist)
+ for LINGUA in $(LINGUAS); do \
+@@ -89,8 +96,7 @@
+ install -m 644 po/$$LINGUA.mo $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES/$(PACKAGE).mo; \
+ sed -e "s/<maintainer>/$(MAINTAINER)/;s/<package>/$(BINPACKAGE)/;s/<version>/$(VERSION)/;s/<language>/$$i/;s!<source>!$(SOURCE)!" $(templates)/control.translation > $(transdist)/$$i/CONTROL/control; \
+ install $(templates)/postinst.translation $(transdist)/$$i/CONTROL/postinst; \
+- chown -R root.root $(transdist)/$$i; \
+- $(IPKG_BUILD) $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
++ $(IPKG_BUILD) -g 0 -o 0 $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
+ done
+
+ translation-ipkg:
diff --git a/packages/gpe-today/gpe-today-0.09/.mtn2git_empty b/packages/gpe-today/gpe-today-0.09/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-today/gpe-today-0.09/.mtn2git_empty
diff --git a/packages/gpe-today/gpe-today-0.09/makefile.patch b/packages/gpe-today/gpe-today-0.09/makefile.patch
new file mode 100644
index 0000000000..6f405a6d7f
--- /dev/null
+++ b/packages/gpe-today/gpe-today-0.09/makefile.patch
@@ -0,0 +1,65 @@
+--- /tmp/Makefile 2005-09-01 17:07:30.218823872 +0200
++++ gpe-today-0.09/Makefile 2005-09-01 17:07:32.698446912 +0200
+@@ -1,7 +1,7 @@
+ PACKAGE = gpe-today
+ PREFIX = /usr/local
+ VERSION = 0.09
+-CVSBUILD = no
++CVSBUILD =no
+ #DEBUG = yes
+ #EFENCE = yes
+
+@@ -9,28 +9,27 @@
+
+ MEMBERS = main todo calendar date xsettings
+
+-GTKCFLAGS = `pkg-config --cflags gtk+-2.0`
+-GTKLDFLAGS += `pkg-config --libs gtk+-2.0`
+-
+-CPPFLAGS = -I../libgpewidget -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -D_GNU_SOURCE
+-
+ ifeq ($(EFENCE),yes)
+-LDFLAGS = -lefence
++PACKAGE_LDFLAGS = -lefence
+ endif
+
+ ifeq ($(DEBUG),yes)
+-CFLAGS = -g
++package_CFLAGS = -g
+ else
+-CFLAGS = -Os -fomit-frame-pointer
++PACKAGE_CFLAGS = -Os -fomit-frame-pointer
+ endif
+
+-CFLAGS += -Wall $(GTKCFLAGS)
+-LDFLAGS += $(GTKLDFLAGS) -L/usr/local/lib -L../libeventdb -leventdb -L../libtododb -ltododb -L../libxsettings -L../libxsettings-client -lXsettings-client -Wl,-rpath-link,../libxsettings -Wl,-rpath-link,../libgpepimc -Wl,-rpath-link,../libdisplaymigration
+-CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+-#CFLAGS += -MD
+-
+ .SUFFIXES: .d
+
++ifeq ($(CVSBUILD),yes)
++PACKAGE_CPPFLAGS += -I../libeventdb -I../libtododb -I../libxsettings -I../libxsettings-client -I../libdisplaymigration -I../libgpepimc
++PACKAGE_LDFLAGS += -L../libeventdb -L../libtododb -L../libxsettings-client -Wl,-rpath-link,../libxsettings -L../libgpepimc
++endif
++PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS)
++PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS)
++PACKAGE_LDFLAGS += $(STANDARD_LDFLAGS) $(GPELIBS) -leventdb -ltododb -lXsettings-client -lsqlite -lgpepimc
++
++
+ OBJS = $(patsubst %,%.o,$(MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS))
+@@ -43,10 +42,10 @@
+ BUILD = build
+ endif
+
+-all: $(PACKAGE) all-mo
++all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) -o $@ $^ -L../libgpewidget -lgpewidget -lsqlite $(LDFLAGS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all $(PACKAGE).desktop
+ for i in $(PIXMAPS); do install -D -m 644 pixmaps/$$i $(DESTDIR)$(PREFIX)/share/$(PACKAGE)/pixmaps/$$i; done
diff --git a/packages/gpe-today/gpe-today_0.08.bb b/packages/gpe-today/gpe-today_0.08.bb
new file mode 100644
index 0000000000..492128a3a5
--- /dev/null
+++ b/packages/gpe-today/gpe-today_0.08.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+inherit gpe
+
+DESCRIPTION = "Displays a summary of appointments and tasks for the day ahead"
+DEPENDS = "gtk+ libxrandr libxsettings libxsettings-client libgpewidget libdisplaymigration libeventdb libgpepimc libtododb"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+SRC_URI += "file://gpe-today_makefiles.patch;patch=1"
diff --git a/packages/gpe-today/gpe-today_0.09.bb b/packages/gpe-today/gpe-today_0.09.bb
new file mode 100644
index 0000000000..916b5ab50f
--- /dev/null
+++ b/packages/gpe-today/gpe-today_0.09.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+inherit gpe
+
+DESCRIPTION = "Displays a summary of appointments and tasks for the day ahead"
+DEPENDS = "gtk+ libxrandr libxsettings libxsettings-client libgpewidget libdisplaymigration libeventdb libgpepimc libtododb"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+SRC_URI += "file://makefile.patch;patch=1"
diff --git a/packages/libgpewidget/libgpewidget_0.112.bb b/packages/libgpewidget/libgpewidget_0.112.bb
new file mode 100644
index 0000000000..cc33e71613
--- /dev/null
+++ b/packages/libgpewidget/libgpewidget_0.112.bb
@@ -0,0 +1,30 @@
+LICENSE = "LGPL"
+DESCRIPTION = "libgpewidget contains a collection of widgets and other common code shared by many GPE applications."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "gtk+ cairo libxrender gtk-doc intltool-native"
+MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
+PR = "r0"
+
+PACKAGES =+ "libgpewidget-bin"
+
+PARALLEL_MAKE = ""
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2 \
+ file://pkgconfig.patch;patch=1;pnum=0"
+
+inherit pkgconfig autotools
+
+FILES_libgpewidget-bin = "${bindir}"
+
+EXTRA_OECONF = "--enable-cairo"
+
+LDFLAGS += " -L${STAGING_LIBDIR}"
+
+do_stage () {
+ autotools_stage_all
+}
+
+do_configure () {
+ autotools_do_configure
+}
diff --git a/packages/xserver-common/xserver-common-1.8/hx4700.patch b/packages/xserver-common/xserver-common-1.8/hx4700.patch
new file mode 100644
index 0000000000..7e286debd7
--- /dev/null
+++ b/packages/xserver-common/xserver-common-1.8/hx4700.patch
@@ -0,0 +1,10 @@
+--- xserver-common-1.8/X11/hx4700.xmodmap.orig 2006-05-13 01:18:59.000000000 +0200
++++ xserver-common-1.8/X11/hx4700.xmodmap 2006-05-13 01:19:02.000000000 +0200
+@@ -1,6 +1,6 @@
+ keycode 75 = XF86Calendar
+ keycode 76 = telephone
+ keycode 95 = XF86Mail
+-keycode 96 = XF86Record
++keycode 96 = XF86AudioRecord
+ keycode 110 = XF86Start
+ keycode 124 = XF86PowerDown