aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/gpe-bluetooth/files/fix-resume-script-name.patch18
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth_0.51.bb3
2 files changed, 21 insertions, 0 deletions
diff --git a/packages/gpe-bluetooth/files/fix-resume-script-name.patch b/packages/gpe-bluetooth/files/fix-resume-script-name.patch
new file mode 100644
index 0000000000..7899afc82f
--- /dev/null
+++ b/packages/gpe-bluetooth/files/fix-resume-script-name.patch
@@ -0,0 +1,18 @@
+--- gpe-bluetooth/Makefile.am 2006/01/15 14:24:00 1.15
++++ gpe-bluetooth/Makefile.am 2006/04/20 11:19:17 1.16
+@@ -46,7 +46,7 @@ pixmaps_extradir = $(datadir)/pixmaps
+ btscriptdir = $(sysconfdir)/bluetooth
+ btscript_SCRIPTS = hciattach.sh
+
+-btresumedir = $(sysconfdir)/apm/resume.d
++btresumedir = $(sysconfdir)/apm/scripts.d
+ btresume_SCRIPTS = gpe-bluetooth-resume.sh
+
+ pingladedir = $(datadir)/bluez-pin
+@@ -83,3 +83,6 @@ install-data-hook:
+ cd $(DESTDIR)$(sysconfdir)/bluetooth && mv hciattach.sh hciattach
+ chmod u+s $(DESTDIR)$(gpebluetoothlibdir)/bnep-helper
+ chmod u+s $(DESTDIR)$(gpebluetoothlibdir)/rfcomm-helper
++ mkdir -p $(DESTDIR)$(sysconfdir)/apm/resume.d
++ cd $(DESTDIR)$(sysconfdir)/apm/resume.d/ && ln -sf ../scripts.d/gpe-bluetooth-resume.sh 50-gpe-bluetooth-resume
++
diff --git a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
index 33bd45d1cc..e02318eaf4 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
+++ b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
@@ -2,6 +2,7 @@ LICENSE = "GPL"
DESCRIPTION = "GPE bluetooth support"
SECTION = "gpe"
PRIORITY = "optional"
+PR = "r1"
DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus libglade blueprobe bluez-utils-dbus"
RDEPENDS = "bluez-utils-dbus blueprobe"
@@ -9,4 +10,6 @@ RDEPENDS = "bluez-utils-dbus blueprobe"
GPE_TARBALL_SUFFIX= "bz2"
inherit gpe autotools
+SRC_URI += "file://fix-resume-script-name.patch;patch=1"
+
FILES_${PN} += '${datadir}/bluez-pin'