aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/efl++/efl++-fb_0.1.0.bb1
-rw-r--r--packages/efl++/efl++-x11_0.1.0.bb3
-rw-r--r--packages/git/files/Makefile.patch13
-rw-r--r--packages/git/git-native_1.4.4.2.bb3
-rw-r--r--packages/git/git-native_snapshot.bb9
-rw-r--r--packages/git/git.inc15
-rw-r--r--packages/git/git_1.4.4.2.bb3
-rw-r--r--packages/git/git_snapshot.bb30
-rw-r--r--packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig2
-rw-r--r--packages/uclibc/uclibc_svn.bb7
-rw-r--r--packages/xserver-common/xserver-common_1.13.bb16
11 files changed, 42 insertions, 60 deletions
diff --git a/packages/efl++/efl++-fb_0.1.0.bb b/packages/efl++/efl++-fb_0.1.0.bb
deleted file mode 100644
index a2e3a7dd34..0000000000
--- a/packages/efl++/efl++-fb_0.1.0.bb
+++ /dev/null
@@ -1 +0,0 @@
-require efl++.inc
diff --git a/packages/efl++/efl++-x11_0.1.0.bb b/packages/efl++/efl++-x11_0.1.0.bb
deleted file mode 100644
index 7f6c942790..0000000000
--- a/packages/efl++/efl++-x11_0.1.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require efl++.inc
-
-EXTRA_QMAKEVARS_POST += "CONFIG+=eflecorex11"
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
deleted file mode 100644
index e360ae917d..0000000000
--- a/packages/git/files/Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git-snapshot-20051008/Makefile
-===================================================================
---- git-snapshot-20051008.orig/Makefile 2005-10-06 00:57:23.000000000 +0100
-+++ git-snapshot-20051008/Makefile 2005-10-08 22:03:50.000000000 +0100
-@@ -332,7 +332,7 @@
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- git-%$X: %.o $(LIB_FILE)
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
-
- git-mailinfo$X : SIMPLE_LIB += $(LIB_4_ICONV)
- $(SIMPLE_PROGRAMS) : $(LIB_FILE)
diff --git a/packages/git/git-native_1.4.4.2.bb b/packages/git/git-native_1.4.4.2.bb
new file mode 100644
index 0000000000..f91fd03ab1
--- /dev/null
+++ b/packages/git/git-native_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native"
diff --git a/packages/git/git-native_snapshot.bb b/packages/git/git-native_snapshot.bb
deleted file mode 100644
index 84e6f96686..0000000000
--- a/packages/git/git-native_snapshot.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require git_snapshot.bb
-inherit native
-DEPENDS = "expat-native openssl-native curl-native"
-
-do_stage () {
- oe_runmake install bindir=${STAGING_BINDIR} \
- template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
- GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
-}
diff --git a/packages/git/git.inc b/packages/git/git.inc
new file mode 100644
index 0000000000..384dfaaeec
--- /dev/null
+++ b/packages/git/git.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+S = "${WORKDIR}/git-${PV}"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+
diff --git a/packages/git/git_1.4.4.2.bb b/packages/git/git_1.4.4.2.bb
new file mode 100644
index 0000000000..37f71cfb04
--- /dev/null
+++ b/packages/git/git_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+DEPENDS = "openssl curl"
+RDEPENDS = "perl perl-module-file-path"
diff --git a/packages/git/git_snapshot.bb b/packages/git/git_snapshot.bb
deleted file mode 100644
index c9048a4673..0000000000
--- a/packages/git/git_snapshot.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DESCRIPTION = "The git revision control system used by the Linux kernel developers"
-DEPENDS = "openssl curl"
-RDEPENDS = "perl \
- perl-module-file-path \
- "
-
-PR = "r2"
-
-def get_git_pkgdate(d):
- import bb
- srcdate = bb.data.getVar('SRCDATE', d, 1)
- return "-".join([srcdate[0:4], srcdate[4:6], srcdate[6:8]])
-
-PKGDATE = "${@get_git_pkgdate(d)}"
-
-SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz"
-PV = "1.4.3.5+snapshot${PKGDATE}"
-
-S = "${WORKDIR}/git-${PKGDATE}"
-
-FILES_${PN} += "${datadir}/git-core"
-
-do_install () {
- oe_runmake install prefix=${D} bindir=${D}${bindir} \
- template_dir=${D}${datadir}/git-core/templates \
- GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-}
-
diff --git a/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig b/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
index 7fadc7ae3a..ea1a929163 100644
--- a/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
+++ b/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
@@ -1405,7 +1405,7 @@ CONFIG_CLASS_LEDS=y
#
# File systems
#
-CONFIG_EXT2_FS=m
+CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
CONFIG_EXT2_FS_POSIX_ACL=y
# CONFIG_EXT2_FS_SECURITY is not set
diff --git a/packages/uclibc/uclibc_svn.bb b/packages/uclibc/uclibc_svn.bb
index ef9c40d463..568f8d46ee 100644
--- a/packages/uclibc/uclibc_svn.bb
+++ b/packages/uclibc/uclibc_svn.bb
@@ -21,9 +21,10 @@ PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-cvs', '${FILE_DIRNAME}/uclibc-${UCLIBC_BASE}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-#as stated above, uclibc needs real kernel-headers
-#however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
-KERNEL_SOURCE = "${STAGING_KERNEL_DIR}"
+# This is the correct KERNEL_SOURCE location, if the uClibc
+# fix_includes.sh script is run (see nokernelheader.patch below)
+# this must be correct.
+KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
SRC_URI += "svn://uclibc.org/trunk;module=uClibc"
diff --git a/packages/xserver-common/xserver-common_1.13.bb b/packages/xserver-common/xserver-common_1.13.bb
new file mode 100644
index 0000000000..d14cad725b
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.13.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}