summaryrefslogtreecommitdiffstats
path: root/recipes/0xFFFF
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/0xFFFF')
-rw-r--r--recipes/0xFFFF/0xffff-native_0.1.bb21
-rw-r--r--recipes/0xFFFF/0xffff-native_0.2.bb21
-rw-r--r--recipes/0xFFFF/0xffff.inc14
-rw-r--r--recipes/0xFFFF/0xffff_0.1.bb6
-rw-r--r--recipes/0xFFFF/0xffff_0.2.bb6
5 files changed, 68 insertions, 0 deletions
diff --git a/recipes/0xFFFF/0xffff-native_0.1.bb b/recipes/0xFFFF/0xffff-native_0.1.bb
new file mode 100644
index 0000000000..2530388d06
--- /dev/null
+++ b/recipes/0xFFFF/0xffff-native_0.1.bb
@@ -0,0 +1,21 @@
+require 0xffff.inc
+
+DEPENDS = "libusb-native"
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 0xFFFF ${STAGING_BINDIR_NATIVE}
+}
+
+do_deploy[dirs] = "${S}"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 755 0xFFFF ${DEPLOY_DIR_IMAGE}
+}
+
+addtask deploy before do_package after do_install
+
+
diff --git a/recipes/0xFFFF/0xffff-native_0.2.bb b/recipes/0xFFFF/0xffff-native_0.2.bb
new file mode 100644
index 0000000000..eb82cb468a
--- /dev/null
+++ b/recipes/0xFFFF/0xffff-native_0.2.bb
@@ -0,0 +1,21 @@
+require 0xffff.inc
+
+DEPENDS = "libusb-native"
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 0xFFFF ${STAGING_BINDIR_NATIVE}
+}
+
+do_deploy[dirs] = "${S}"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 755 0xFFFF ${DEPLOY_DIR_IMAGE}
+}
+
+addtask deploy before do_package after do_install
+
+
diff --git a/recipes/0xFFFF/0xffff.inc b/recipes/0xFFFF/0xffff.inc
new file mode 100644
index 0000000000..db281467ed
--- /dev/null
+++ b/recipes/0xFFFF/0xffff.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "The 'Open Free Fiasco Firmware Flasher' aka 0xFFFF utility aims to implement a free (GPL'd) userspace handler for the NOLO bootloader."
+LICENSE = "GPLv3"
+
+SRC_URI = "http://www.nopcode.org/0xFFFF/get/0xFFFF-${PV}.tar.gz"
+
+S = "${WORKDIR}/0xFFFF-${PV}/src"
+
+CFLAGS += '-DVERSION="${PV}" -I.'
+BUILD_CFLAGS += '-DVERSION="${PV}" -I.'
+
+do_compile() {
+ oe_runmake
+}
+
diff --git a/recipes/0xFFFF/0xffff_0.1.bb b/recipes/0xFFFF/0xffff_0.1.bb
new file mode 100644
index 0000000000..fb3b93d415
--- /dev/null
+++ b/recipes/0xFFFF/0xffff_0.1.bb
@@ -0,0 +1,6 @@
+require 0xffff.inc
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 0xFFFF ${D}${bindir}
+}
diff --git a/recipes/0xFFFF/0xffff_0.2.bb b/recipes/0xFFFF/0xffff_0.2.bb
new file mode 100644
index 0000000000..fb3b93d415
--- /dev/null
+++ b/recipes/0xFFFF/0xffff_0.2.bb
@@ -0,0 +1,6 @@
+require 0xffff.inc
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 0xFFFF ${D}${bindir}
+}