aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aircrack/aircrack-ng_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aircrack/aircrack-ng_0.9.3.bb')
-rw-r--r--recipes/aircrack/aircrack-ng_0.9.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/aircrack/aircrack-ng_0.9.3.bb b/recipes/aircrack/aircrack-ng_0.9.3.bb
new file mode 100644
index 0000000000..1452a64bc1
--- /dev/null
+++ b/recipes/aircrack/aircrack-ng_0.9.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Aircrack-ng is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.aircrack-ng.org/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://download.aircrack-ng.org/aircrack-ng-${PV}.tar.gz"
+
+SBINFILES = "airodump-ng aireplay-ng airmon-ng airtun-ng"
+BINFILES = "aircrack-ng airdecap-ng packetforge-ng ivstools kstats makeivs"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ for i in ${SBINFILES}; do
+ install -m 0755 $i ${D}/${sbindir}
+ done
+
+ install -d ${D}/${bindir}
+ for i in ${BINFILES}; do
+ install -m 0755 $i ${D}/${bindir}
+ done
+}