aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/alsa/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/alsa/files')
-rw-r--r--recipes/alsa/files/alsa-utils-autoconf-strl-funcs.patch43
-rw-r--r--recipes/alsa/files/alsa-utils-automake.patch10
-rw-r--r--recipes/alsa/files/alsa-utils-remove-xmlto.patch15
-rw-r--r--recipes/alsa/files/alsa-utils-sys-siglist.patch15
-rw-r--r--recipes/alsa/files/libio.patch43
5 files changed, 126 insertions, 0 deletions
diff --git a/recipes/alsa/files/alsa-utils-autoconf-strl-funcs.patch b/recipes/alsa/files/alsa-utils-autoconf-strl-funcs.patch
new file mode 100644
index 0000000000..d736abbdab
--- /dev/null
+++ b/recipes/alsa/files/alsa-utils-autoconf-strl-funcs.patch
@@ -0,0 +1,43 @@
+Index: alsa-utils-1.0.18/alsactl/init_sysdeps.c
+===================================================================
+--- alsa-utils-1.0.18.orig/alsactl/init_sysdeps.c 2008-10-29 05:42:11.000000000 -0700
++++ alsa-utils-1.0.18/alsactl/init_sysdeps.c 2009-02-10 23:17:47.000000000 -0800
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#ifdef __GLIBC__
++#if !HAVE_STRLCPY
+ static size_t strlcpy(char *dst, const char *src, size_t size)
+ {
+ size_t bytes = 0;
+@@ -36,7 +36,10 @@
+ *q = '\0';
+ return bytes;
+ }
++#endif /* !HAVE_STRLCPY */
+
++
++#if !HAVE_STRLCAT
+ static size_t strlcat(char *dst, const char *src, size_t size)
+ {
+ size_t bytes = 0;
+@@ -60,4 +63,4 @@
+ *q = '\0';
+ return bytes;
+ }
+-#endif /* __GLIBC__ */
++#endif /* !HAVE_STRLCAT */
+Index: alsa-utils-1.0.18/configure.in
+===================================================================
+--- alsa-utils-1.0.18.orig/configure.in 2008-10-29 05:48:01.000000000 -0700
++++ alsa-utils-1.0.18/configure.in 2009-02-10 23:02:07.000000000 -0800
+@@ -6,7 +6,7 @@
+
+ AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.15])
+-
++AC_CHECK_FUNCS([strlcat strlcpy])
+ dnl Checks for programs.
+
+ dnl try to gues cross-compiler if not set
diff --git a/recipes/alsa/files/alsa-utils-automake.patch b/recipes/alsa/files/alsa-utils-automake.patch
new file mode 100644
index 0000000000..de0eee94fd
--- /dev/null
+++ b/recipes/alsa/files/alsa-utils-automake.patch
@@ -0,0 +1,10 @@
+Index: alsa-utils-1.0.14/seq/aseqnet/Makefile.am
+===================================================================
+--- alsa-utils-1.0.14.orig/seq/aseqnet/Makefile.am 2007-05-31 10:07:21.000000000 +0200
++++ alsa-utils-1.0.14/seq/aseqnet/Makefile.am 2007-10-31 21:11:41.000000000 +0100
+@@ -3,4 +3,5 @@
+
+ bin_PROGRAMS = aseqnet
+ aseqnet_SOURCES = aseqnet.c
++aseqnet_LDADD = $(INTLLIBS)
+ man_MANS = aseqnet.1
diff --git a/recipes/alsa/files/alsa-utils-remove-xmlto.patch b/recipes/alsa/files/alsa-utils-remove-xmlto.patch
new file mode 100644
index 0000000000..a02bdba5aa
--- /dev/null
+++ b/recipes/alsa/files/alsa-utils-remove-xmlto.patch
@@ -0,0 +1,15 @@
+--- alsa-utils-1.0.18.orig/alsactl/Makefile.am 2008-10-29 12:42:11.000000000 +0000
++++ alsa-utils-1.0.18/alsactl/Makefile.am 2009-01-21 23:43:19.000000000 +0000
+@@ -1,11 +1,8 @@
+ SUBDIRS = init
+
+ sbin_PROGRAMS=alsactl
+-man_MANS=alsactl.1 alsactl_init.7
++man_MANS=alsactl.1
+ EXTRA_DIST=alsactl.1 alsactl_init.xml
+
+ alsactl_SOURCES=alsactl.c state.c utils.c init_parse.c
+ noinst_HEADERS=alsactl.h list.h init_sysdeps.c init_utils_string.c init_utils_run.c init_sysfs.c
+-
+-%.7: %.xml
+- xmlto man $?
diff --git a/recipes/alsa/files/alsa-utils-sys-siglist.patch b/recipes/alsa/files/alsa-utils-sys-siglist.patch
new file mode 100644
index 0000000000..8c499e8d63
--- /dev/null
+++ b/recipes/alsa/files/alsa-utils-sys-siglist.patch
@@ -0,0 +1,15 @@
+sys_siglist is not supported by default on uclibc and is, in general,
+a bad thing for the same reasons as sys_errlist is a bad thing. GNU
+supports strsignal in the manner of strerror
+
+--- alsa-utils-1.0.8/alsamixer/alsamixer.c.orig 2005-09-06 12:44:41.415219126 -0700
++++ alsa-utils-1.0.8/alsamixer/alsamixer.c 2005-09-06 12:44:43.407344482 -0700
+@@ -2188,7 +2188,7 @@
+ mixer_signal_handler (int signal)
+ {
+ if (signal != SIGSEGV)
+- mixer_abort (ERR_SIGNAL, sys_siglist[signal], 0);
++ mixer_abort (ERR_SIGNAL, strsignal(signal), 0);
+ else
+ {
+ fprintf (stderr, "\nSegmentation fault.\n");
diff --git a/recipes/alsa/files/libio.patch b/recipes/alsa/files/libio.patch
new file mode 100644
index 0000000000..a053e4c604
--- /dev/null
+++ b/recipes/alsa/files/libio.patch
@@ -0,0 +1,43 @@
+Index: alsa-oss-1.0.15/alsa/stdioemu.c
+===================================================================
+--- alsa-oss-1.0.15.orig/alsa/stdioemu.c 2007-10-15 10:50:40.000000000 +0200
++++ alsa-oss-1.0.15/alsa/stdioemu.c 2008-07-21 22:17:06.303161438 +0200
+@@ -37,7 +37,9 @@
+ #endif
+
+ #include <stdio.h>
++#ifdef HAVE_LIBIO_H
+ #include <libio.h>
++#endif
+
+ struct fd_cookie {
+ int fd;
+@@ -99,7 +101,11 @@
+
+ if (open_mode && fdc->fd > 0) {
+ result = fopencookie (fdc,"w", fns);
++#ifdef HAVE_FILENO
+ result->_fileno = fdc->fd; /* ugly patchy slimy kludgy hack */
++#else
++ result->__filedes = fdc->fd;
++#endif
+ }
+ return result;
+ }
+Index: alsa-oss-1.0.15/configure.in
+===================================================================
+--- alsa-oss-1.0.15.orig/configure.in 2007-10-15 10:50:40.000000000 +0200
++++ alsa-oss-1.0.15/configure.in 2008-07-21 22:16:11.719837298 +0200
+@@ -33,6 +33,12 @@
+ LIBS="$OLD_LIBS"
+ fi
+
++AC_CHECK_HEADERS_ONCE([libio.h])
++
++AC_CHECK_MEMBER([struct _IO_FILE._fileno],
++ [AC_DEFINE([HAVE_FILENO], [1],[Define if _fileno exists.])],
++ [],[])
++
+ AC_OUTPUT(Makefile alsa/Makefile alsa/aoss alsa/aoss.old \
+ oss-redir/Makefile test/Makefile \
+ alsa/testaoss test/testaoss)