aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom/angstrom-libc-fixup-hack.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/angstrom/angstrom-libc-fixup-hack.bb')
-rw-r--r--recipes/angstrom/angstrom-libc-fixup-hack.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-libc-fixup-hack.bb b/recipes/angstrom/angstrom-libc-fixup-hack.bb
new file mode 100644
index 0000000000..bf4339a031
--- /dev/null
+++ b/recipes/angstrom/angstrom-libc-fixup-hack.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Fixup some miscompiled apps by making an extra symlink"
+
+PACKAGE_ARCH = "all"
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+ln -sf /lib/libc.so.6 /lib/libc.so
+}