aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom/angstrom-x11vnc-xinit.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/angstrom/angstrom-x11vnc-xinit.bb')
-rw-r--r--recipes/angstrom/angstrom-x11vnc-xinit.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-x11vnc-xinit.bb b/recipes/angstrom/angstrom-x11vnc-xinit.bb
new file mode 100644
index 0000000000..ee21d81e03
--- /dev/null
+++ b/recipes/angstrom/angstrom-x11vnc-xinit.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Script to start a passwordless vnc of the current X session"
+LICENSE = "MIT"
+RDEPENDS = "x11vnc"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/X11/Xinit.d
+ echo "#!/bin/sh" > ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ echo "x11vnc -q -bg -display :0 -forever -avahi" >> ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ chmod 0755 ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+}
+
+CONFFILES_${PN} += "${sysconfdir}/X11/Xinit.d/02vnc"
+PACKAGE_ARCH = "all"
+