aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom/e-wm-config-angstrom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/angstrom/e-wm-config-angstrom.bb')
-rw-r--r--recipes/angstrom/e-wm-config-angstrom.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/angstrom/e-wm-config-angstrom.bb b/recipes/angstrom/e-wm-config-angstrom.bb
new file mode 100644
index 0000000000..a2c6f93657
--- /dev/null
+++ b/recipes/angstrom/e-wm-config-angstrom.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Enlightenment DR17 theme for Angstrom"
+LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+RDEPENDS = "e-wm"
+RRECOMMENDS_${PN} = "places"
+
+PR = "r4"
+
+SRC_URI = " \
+ file://e.src \
+ file://icon.png \
+ file://*.src \
+ file://profile.desktop \
+ "
+S = "${WORKDIR}/angstrom"
+
+do_configure() {
+ cp ${WORKDIR}/*.src ${WORKDIR}/*.desktop ${WORKDIR}/*.png ${S}/
+}
+
+
+do_compile() {
+ for i in *.src ; do
+ eet -e $(echo $i | sed s:src:cfg:g) config $i 1
+ done
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/config/angstrom/
+
+ install -m 0644 ${S}/*.cfg ${D}${datadir}/enlightenment/data/config/angstrom/
+ install -m 0644 ${S}/*.desktop ${D}${datadir}/enlightenment/data/config/angstrom/
+ install -m 0644 ${S}/*.png ${D}${datadir}/enlightenment/data/config/angstrom/
+}
+
+FILES_${PN} = "${datadir}/enlightenment"
+
+PACKAGE_ARCH_${PN} = "all"
+