summaryrefslogtreecommitdiffstats
path: root/recipes/angstrom
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/angstrom')
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts.bb2
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts/esc-sxga.cmd4
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts/mtest.cmd12
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts/ramdisk.cmd5
4 files changed, 22 insertions, 1 deletions
diff --git a/recipes/angstrom/angstrom-uboot-scripts.bb b/recipes/angstrom/angstrom-uboot-scripts.bb
index 2af6a74378..033a26013f 100644
--- a/recipes/angstrom/angstrom-uboot-scripts.bb
+++ b/recipes/angstrom/angstrom-uboot-scripts.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Various uboot scripts"
-PR = "r2"
+PR = "r3"
DEPENDS = "u-boot-mkimage-native"
diff --git a/recipes/angstrom/angstrom-uboot-scripts/esc-sxga.cmd b/recipes/angstrom/angstrom-uboot-scripts/esc-sxga.cmd
new file mode 100644
index 0000000000..7a50ad5d63
--- /dev/null
+++ b/recipes/angstrom/angstrom-uboot-scripts/esc-sxga.cmd
@@ -0,0 +1,4 @@
+setenv bootargs 'console=tty0 console=ttyS2,115200n8 mpurate=1000 nohz=off vram=16M omapfb.mode=dvi:1280x1024MR-24@60 omapdss.def_disp=dvi omapfb.vram=0:8M,1:4M,2:4M root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait mem=99M@0x80000000 mem=384M@0x88000000'
+fatload mmc 0 0x82000000 uImage
+bootm 0x82000000
+EOF
diff --git a/recipes/angstrom/angstrom-uboot-scripts/mtest.cmd b/recipes/angstrom/angstrom-uboot-scripts/mtest.cmd
new file mode 100644
index 0000000000..ee25ed77f1
--- /dev/null
+++ b/recipes/angstrom/angstrom-uboot-scripts/mtest.cmd
@@ -0,0 +1,12 @@
+# This tests the BeagleBoard-xM memory using 'mtest'
+#
+# While running, LED D7 (USR0) toggles within about 10 seconds
+# On fail, LED D6 (USR1) is on
+# On pass, LED D7 (USR0) stops toggling and LED D6 (USR1) is off
+#
+# Completion occurs then the u-boot call stack overflows
+setenv test_mem 'mtest 0x8fff0000 0x90010000 0 0x20'
+setenv test_on 'if run test_mem; then led 0 on; run test_off; else led 1 on; fi'
+setenv test_off 'if run test_mem; then led 0 off; run test_on; else led 1 on; fi'
+setenv test 'led all off; run test_on'
+run test
diff --git a/recipes/angstrom/angstrom-uboot-scripts/ramdisk.cmd b/recipes/angstrom/angstrom-uboot-scripts/ramdisk.cmd
new file mode 100644
index 0000000000..68af249928
--- /dev/null
+++ b/recipes/angstrom/angstrom-uboot-scripts/ramdisk.cmd
@@ -0,0 +1,5 @@
+#setenv bootargs 'console=tty0 console=ttyS2,115200n8 mpurate=1000 nohz=off vram=16M omapfb.mode=dvi:640x480MR-16@60 omapdss.def_disp=dvi omapfb.vram=0:8M,1:4M,2:4M root=/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,32M ramdisk_size=32768 mem=99M@0x80000000 mem=384M@0x88000000'
+setenv bootargs 'console=tty0 console=ttyS2,115200n8 root=/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,32M ramdisk_size=32768'
+fatload mmc 0 0x80200000 uImage
+fatload mmc 0 0x81600000 ramdisk.gz
+bootm 0x80200000