aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/antlr/antlr-native_2.7.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/antlr/antlr-native_2.7.7.bb')
-rw-r--r--recipes/antlr/antlr-native_2.7.7.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/antlr/antlr-native_2.7.7.bb b/recipes/antlr/antlr-native_2.7.7.bb
new file mode 100644
index 0000000000..871e620b93
--- /dev/null
+++ b/recipes/antlr/antlr-native_2.7.7.bb
@@ -0,0 +1,17 @@
+require antlr_${PV}.bb
+
+SRC_URI += "file://runantlr"
+
+inherit java-native
+
+do_configure() {
+ sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_NATIVE}/java/antlr.jar|" ${WORKDIR}/runantlr
+}
+
+do_stage() {
+ java_stage
+
+ install -d ${STAGING_BINDIR}
+
+ install -m 0755 ${WORKDIR}/runantlr ${STAGING_BINDIR}
+}