aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/appweb/appweb-1.2.0/makerules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/appweb/appweb-1.2.0/makerules.patch')
-rw-r--r--recipes/appweb/appweb-1.2.0/makerules.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/appweb/appweb-1.2.0/makerules.patch b/recipes/appweb/appweb-1.2.0/makerules.patch
new file mode 100644
index 0000000000..55d3dd22d9
--- /dev/null
+++ b/recipes/appweb/appweb-1.2.0/makerules.patch
@@ -0,0 +1,34 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- appWeb-1.2.0/make.rules~makerules 2004-06-28 14:50:23.000000000 -0500
++++ appWeb-1.2.0/make.rules 2004-07-15 13:27:35.000000000 -0500
+@@ -61,24 +61,19 @@
+ for i in $$D "" ; \
+ do [ -z "$$i" ] && continue ;\
+ [ -d "$$i" ] || continue ;\
+- home=`pwd` ; \
+- cd "$$i" >/dev/null ; \
+- if [ -f Makefile ] ; then \
++ if [ -f $$i/Makefile ] ; then \
+ echo ; \
+- echo " cd $$i" ; \
+ set +e ; \
+ unset COMPILE_SHARED EXPORT_OBJECTS _LDPATH ; \
+ set -e ; \
+ echo " \# $(MAKE) $$T" ; \
+- $(MAKE) --no-print-directory -S $$T ; \
++ $(MAKE) -C $$i --no-print-directory -S $$T ; \
+ code=$$? ; \
+ if [ $$code != 0 ] ; then \
+ echo "\#WARNING: Makefile error in `pwd`" ; \
+ exit 255 ; \
+ fi ; \
+- echo " cd $$home" ; \
+ fi ; \
+- cd $$home >/dev/null ;\
+ done
+
+ DO_RECURSE=[ -z "$$D" ] || $(RECURSE)