aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/appweb/appweb-1.2.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/appweb/appweb-1.2.0')
-rw-r--r--recipes/appweb/appweb-1.2.0/makerules.patch34
-rw-r--r--recipes/appweb/appweb-1.2.0/nonrootinstall.patch57
2 files changed, 91 insertions, 0 deletions
diff --git a/recipes/appweb/appweb-1.2.0/makerules.patch b/recipes/appweb/appweb-1.2.0/makerules.patch
new file mode 100644
index 0000000000..55d3dd22d9
--- /dev/null
+++ b/recipes/appweb/appweb-1.2.0/makerules.patch
@@ -0,0 +1,34 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- appWeb-1.2.0/make.rules~makerules 2004-06-28 14:50:23.000000000 -0500
++++ appWeb-1.2.0/make.rules 2004-07-15 13:27:35.000000000 -0500
+@@ -61,24 +61,19 @@
+ for i in $$D "" ; \
+ do [ -z "$$i" ] && continue ;\
+ [ -d "$$i" ] || continue ;\
+- home=`pwd` ; \
+- cd "$$i" >/dev/null ; \
+- if [ -f Makefile ] ; then \
++ if [ -f $$i/Makefile ] ; then \
+ echo ; \
+- echo " cd $$i" ; \
+ set +e ; \
+ unset COMPILE_SHARED EXPORT_OBJECTS _LDPATH ; \
+ set -e ; \
+ echo " \# $(MAKE) $$T" ; \
+- $(MAKE) --no-print-directory -S $$T ; \
++ $(MAKE) -C $$i --no-print-directory -S $$T ; \
+ code=$$? ; \
+ if [ $$code != 0 ] ; then \
+ echo "\#WARNING: Makefile error in `pwd`" ; \
+ exit 255 ; \
+ fi ; \
+- echo " cd $$home" ; \
+ fi ; \
+- cd $$home >/dev/null ;\
+ done
+
+ DO_RECURSE=[ -z "$$D" ] || $(RECURSE)
diff --git a/recipes/appweb/appweb-1.2.0/nonrootinstall.patch b/recipes/appweb/appweb-1.2.0/nonrootinstall.patch
new file mode 100644
index 0000000000..4227b76591
--- /dev/null
+++ b/recipes/appweb/appweb-1.2.0/nonrootinstall.patch
@@ -0,0 +1,57 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- appWeb-1.2.0/Makefile~nonrootinstall 2004-07-06 15:09:21.000000000 -0500
++++ appWeb-1.2.0/Makefile 2004-07-15 13:45:32.000000000 -0500
+@@ -127,40 +127,33 @@
+ #
+ # Installation targets
+ #
+-install: install-rootCheck install-binary
+-
+-install-rootCheck:
+- @if [ $(BLD_OS) != WIN -a `id -u` -ne 0 ] ; \
+- then \
+- echo "Must be root to install" ; \
+- exit 255 ; \
+- fi
++install: install-binary
+
+-install-release: install-rootCheck
++install-release:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall release
+
+-install-binary: install-rootCheck
++install-binary:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall binary
+ @echo -e " #\n # To start ${BLD_NAME}, run as root:\n #"
+ @echo -e " service ${BLD_PRODUCT} start\n"
+
+-install-dev: install-rootCheck
++install-dev:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall dev
+
+-install-doc: install-rootCheck
++install-doc:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall doc
+
+-install-samples: install-rootCheck
++install-samples:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall samples
+
+-install-source: install-rootCheck
++install-source:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall source
+
+-install-all: install-rootCheck
++install-all:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeInstall \
+ "release binary dev doc samples source"
+
+-uninstall: install-rootCheck
++uninstall:
+ @$(BLD_PRODUCT)/package/$(BLD_OS)/makeUninstall
+
+ #