aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apr/apr-util_1.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apr/apr-util_1.2.7.bb')
-rw-r--r--recipes/apr/apr-util_1.2.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/apr/apr-util_1.2.7.bb b/recipes/apr/apr-util_1.2.7.bb
new file mode 100644
index 0000000000..5f019d624e
--- /dev/null
+++ b/recipes/apr/apr-util_1.2.7.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r3"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configure_fixes.patch;patch=1"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+do_stage() {
+ autotools_stage_all
+}