aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apt/apt-0.7.20.2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apt/apt-0.7.20.2')
-rw-r--r--recipes/apt/apt-0.7.20.2/no-curl.patch40
-rw-r--r--recipes/apt/apt-0.7.20.2/noconfigure.patch35
-rw-r--r--recipes/apt/apt-0.7.20.2/nodoc.patch19
3 files changed, 94 insertions, 0 deletions
diff --git a/recipes/apt/apt-0.7.20.2/no-curl.patch b/recipes/apt/apt-0.7.20.2/no-curl.patch
new file mode 100644
index 0000000000..3e5aff139c
--- /dev/null
+++ b/recipes/apt/apt-0.7.20.2/no-curl.patch
@@ -0,0 +1,40 @@
+---
+ configure.in | 6 ------
+ methods/makefile | 7 -------
+ 2 files changed, 13 deletions(-)
+
+Index: apt-0.7.19/configure.in
+===================================================================
+--- apt-0.7.19.orig/configure.in 2008-12-15 13:44:44.000000000 +0000
++++ apt-0.7.19/configure.in 2008-12-15 13:57:16.000000000 +0000
+@@ -86,12 +86,6 @@
+
+ LIBS="$saveLIBS"
+
+-AC_CHECK_LIB(curl, curl_easy_init,
+- [AC_CHECK_HEADER(curl/curl.h,
+- curl_ok=yes,
+- curl_ok=no)],
+- AC_MSG_ERROR([failed: I need CURL due https support]),
+-)
+
+ AC_SUBST(BDBLIB)
+
+Index: apt-0.7.19/methods/makefile
+===================================================================
+--- apt-0.7.19.orig/methods/makefile 2008-11-24 09:32:23.000000000 +0000
++++ apt-0.7.19/methods/makefile 2008-12-15 13:57:44.000000000 +0000
+@@ -52,13 +52,6 @@
+ SOURCE = http.cc rfc2553emu.cc connect.cc
+ include $(PROGRAM_H)
+
+-# The https method
+-PROGRAM=https
+-SLIBS = -lapt-pkg -lcurl $(INTLLIBS)
+-LIB_MAKES = apt-pkg/makefile
+-SOURCE = https.cc
+-include $(PROGRAM_H)
+-
+ # The ftp method
+ PROGRAM=ftp
+ SLIBS = -lapt-pkg $(SOCKETLIBS) $(INTLLIBS)
diff --git a/recipes/apt/apt-0.7.20.2/noconfigure.patch b/recipes/apt/apt-0.7.20.2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/recipes/apt/apt-0.7.20.2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/recipes/apt/apt-0.7.20.2/nodoc.patch b/recipes/apt/apt-0.7.20.2/nodoc.patch
new file mode 100644
index 0000000000..db8cf93717
--- /dev/null
+++ b/recipes/apt/apt-0.7.20.2/nodoc.patch
@@ -0,0 +1,19 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.7.14.orig/Makefile
++++ apt-0.7.14/Makefile
+@@ -15,11 +15,11 @@ all headers library clean veryclean bina
+ $(MAKE) -C apt-inst $@
+ $(MAKE) -C methods $@
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
+ .PHONY: maintainer-clean dist-clean distclean pristine sanity
+ maintainer-clean dist-clean distclean pristine sanity: veryclean