aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apt/apt-0.7.2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apt/apt-0.7.2')
-rw-r--r--recipes/apt/apt-0.7.2/noconfigure.patch35
-rw-r--r--recipes/apt/apt-0.7.2/nodoc.patch15
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes/apt/apt-0.7.2/noconfigure.patch b/recipes/apt/apt-0.7.2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/recipes/apt/apt-0.7.2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/recipes/apt/apt-0.7.2/nodoc.patch b/recipes/apt/apt-0.7.2/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/recipes/apt/apt-0.7.2/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases