summaryrefslogtreecommitdiffstats
path: root/recipes/apt/files/db_linking_hack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apt/files/db_linking_hack.patch')
-rw-r--r--recipes/apt/files/db_linking_hack.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/apt/files/db_linking_hack.patch b/recipes/apt/files/db_linking_hack.patch
new file mode 100644
index 0000000000..3c8368b1ed
--- /dev/null
+++ b/recipes/apt/files/db_linking_hack.patch
@@ -0,0 +1,27 @@
+Index: apt-0.7.3/configure.in
+===================================================================
+--- apt-0.7.3.orig/configure.in 2007-07-01 10:38:45.000000000 +0000
++++ apt-0.7.3/configure.in 2007-08-21 13:39:26.000000000 +0000
+@@ -67,8 +67,20 @@
+ [AC_DEFINE(HAVE_BDB)
+ BDBLIB="-ldb"
+ AC_MSG_RESULT(yes)],
+- [BDBLIB=""
+- AC_MSG_RESULT(no)]
++
++ LIBS="$LIBS -lpthread"
++ [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread)
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [#include <db.h>],
++ [int r, s, t; db_version(&r, &s, &t);]
++ )],
++ [AC_DEFINE(HAVE_BDB)
++ BDBLIB="-ldb -lpthread"
++ AC_MSG_RESULT(yes)],
++ [BDBLIB=""
++ AC_MSG_RESULT(no)]
++ )]
+ )]
+ )
+