aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/at76c503a/at76c503a-modules
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/at76c503a/at76c503a-modules')
-rw-r--r--recipes/at76c503a/at76c503a-modules/at76_usb-0.17-.patch66
-rw-r--r--recipes/at76c503a/at76c503a-modules/makefile.cc.patch11
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/at76c503a/at76c503a-modules/at76_usb-0.17-.patch b/recipes/at76c503a/at76c503a-modules/at76_usb-0.17-.patch
new file mode 100644
index 0000000000..06200f5ac7
--- /dev/null
+++ b/recipes/at76c503a/at76c503a-modules/at76_usb-0.17-.patch
@@ -0,0 +1,66 @@
+--- at76_usb-0.17/at76_usb.c 2007-09-30 09:21:38.000000000 +0200
++++ at76_usb-0.17.1/at76_usb.c 2008-12-02 17:29:15.000000000 +0100
+@@ -2327,7 +2327,7 @@
+ iwe->cmd = SIOCGIWAP;
+ iwe->u.ap_addr.sa_family = ARPHRD_ETHER;
+ memcpy(iwe->u.ap_addr.sa_data, curr_bss->bssid, 6);
+- curr_pos = iwe_stream_add_event(curr_pos,
++ curr_pos = iwe_stream_add_event(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ IW_EV_ADDR_LEN);
+
+@@ -2335,7 +2335,7 @@
+ iwe->cmd = SIOCGIWESSID;
+ iwe->u.data.flags = 1;
+
+- curr_pos = iwe_stream_add_point(curr_pos,
++ curr_pos = iwe_stream_add_point(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ curr_bss->ssid);
+
+@@ -2346,14 +2346,14 @@
+ IW_MODE_MASTER : IW_MODE_AUTO;
+ /* IW_MODE_AUTO = 0 which I thought is
+ * the most logical value to return in this case */
+- curr_pos = iwe_stream_add_event(curr_pos,
++ curr_pos = iwe_stream_add_event(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ IW_EV_UINT_LEN);
+
+ iwe->cmd = SIOCGIWFREQ;
+ iwe->u.freq.m = curr_bss->channel;
+ iwe->u.freq.e = 0;
+- curr_pos = iwe_stream_add_event(curr_pos,
++ curr_pos = iwe_stream_add_event(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ IW_EV_FREQ_LEN);
+
+@@ -2364,7 +2364,7 @@
+ iwe->u.data.flags = IW_ENCODE_DISABLED;
+
+ iwe->u.data.length = 0;
+- curr_pos = iwe_stream_add_point(curr_pos,
++ curr_pos = iwe_stream_add_point(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ NULL);
+
+@@ -2383,7 +2383,7 @@
+ iwe->u.qual.updated |= IW_QUAL_QUAL_INVALID;
+ }
+ /* Add new value to event */
+- curr_pos = iwe_stream_add_event(curr_pos,
++ curr_pos = iwe_stream_add_event(info, curr_pos,
+ extra + IW_SCAN_MAX_DATA, iwe,
+ IW_EV_QUAL_LEN);
+
+@@ -2401,8 +2401,8 @@
+ iwe->u.bitrate.value =
+ ((curr_bss->rates[i] & 0x7f) * 500000);
+ /* Add new value to event */
+- curr_val = iwe_stream_add_value(curr_pos, curr_val,
+- extra +
++ curr_val = iwe_stream_add_value(info, curr_pos,
++ curr_val, extra +
+ IW_SCAN_MAX_DATA, iwe,
+ IW_EV_PARAM_LEN);
+ }
diff --git a/recipes/at76c503a/at76c503a-modules/makefile.cc.patch b/recipes/at76c503a/at76c503a-modules/makefile.cc.patch
new file mode 100644
index 0000000000..c7a41990d3
--- /dev/null
+++ b/recipes/at76c503a/at76c503a-modules/makefile.cc.patch
@@ -0,0 +1,11 @@
+--- at76c503a/Makefile.old 2005-07-29 21:57:34.000000000 +0200
++++ at76c503a/Makefile 2005-07-29 21:57:43.000000000 +0200
+@@ -9,7 +9,7 @@
+ # the License, or (at your option) any later version.
+ #
+
+-CC=gcc
++#CC=gcc
+
+ ifneq (,$(KVERS))
+ KERNEL_VERSION=$(KVERS)