aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/atd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/atd')
-rw-r--r--recipes/atd/atd_0.70.bb27
-rw-r--r--recipes/atd/atd_0.80.bb14
-rw-r--r--recipes/atd/files/atd-startup.patch39
-rw-r--r--recipes/atd/files/no-oknodo.patch11
4 files changed, 91 insertions, 0 deletions
diff --git a/recipes/atd/atd_0.70.bb b/recipes/atd/atd_0.70.bb
new file mode 100644
index 0000000000..9862fac0dd
--- /dev/null
+++ b/recipes/atd/atd_0.70.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Lightweight At Daemon"
+SECTION = "base"
+LICENSE = "GPLV2"
+RCONFLICTS = "at"
+RREPLACES = "at"
+
+PR = "r4"
+
+SRC_URI = "${HANDHELDS_CVS};module=apps/atd;tag=ATD-0_70 \
+ file://atd-startup.patch;patch=1;pnum=0"
+S = "${WORKDIR}/atd"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "atd"
+INITSCRIPT_PARAMS = "defaults 97"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install atd ${D}${sbindir}/atd
+ install -d ${D}${sysconfdir}/init.d
+ install dist/etc/init.d/atd ${D}${sysconfdir}/init.d/atd
+}
diff --git a/recipes/atd/atd_0.80.bb b/recipes/atd/atd_0.80.bb
new file mode 100644
index 0000000000..f3adbd7cb3
--- /dev/null
+++ b/recipes/atd/atd_0.80.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Lightweight At Daemon"
+SECTION = "base"
+LICENSE = "GPLV2"
+RCONFLICTS = "at"
+RREPLACES = "at"
+
+PR = "r0"
+
+SRC_URI = "http://projects.linuxtogo.org/frs/download.php/222/${P}.tar.gz"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "atd"
+INITSCRIPT_PARAMS = "defaults 97"
diff --git a/recipes/atd/files/atd-startup.patch b/recipes/atd/files/atd-startup.patch
new file mode 100644
index 0000000000..dc4c1195d1
--- /dev/null
+++ b/recipes/atd/files/atd-startup.patch
@@ -0,0 +1,39 @@
+? atd-startup.patch
+Index: ChangeLog
+===================================================================
+RCS file: /cvs/apps/atd/ChangeLog,v
+retrieving revision 1.2
+diff -B -b -u -r1.2 ChangeLog
+--- ChangeLog 2 Feb 2004 15:30:39 -0000 1.2
++++ ChangeLog 13 Jan 2006 11:54:00 -0000
+@@ -1,3 +1,8 @@
++2006-01-13 Florian Boor <florian@kernelconcepts.de>
++
++ * dist/etc/init.d/atd: Remove obsolete --oknodo and add -m to
++ enable pidfile.
++
+ V0.7
+ - removed waiting for childpid after having spawned an event
+ this caused trouble with events rescheduling themselves
+Index: dist/etc/init.d/atd
+===================================================================
+RCS file: /cvs/apps/atd/dist/etc/init.d/atd,v
+retrieving revision 1.3
+diff -B -b -u -r1.3 atd
+--- dist/etc/init.d/atd 24 Jan 2003 15:09:03 -0000 1.3
++++ dist/etc/init.d/atd 13 Jan 2006 11:54:00 -0000
+@@ -11,12 +11,12 @@
+ echo -n "Starting at daemon: atd"
+ mkdir -p /var/spool/at
+ chmod a+w /var/spool/at
+- start-stop-daemon --start --quiet --pidfile /var/run/atd.pid --exec /usr/sbin/atd /var/spool/at >/dev/null 2>&1 &
++ start-stop-daemon --start --quiet -m --pidfile /var/run/atd.pid --exec /usr/sbin/atd /var/spool/at >/dev/null 2>&1 &
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping at daemon: atd"
+- start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/atd.pid --exec /usr/sbin/atd
++ start-stop-daemon --stop --quiet --pidfile /var/run/atd.pid --exec /usr/sbin/atd
+ rm -f /var/spool/at/trigger
+ echo "."
+ ;;
diff --git a/recipes/atd/files/no-oknodo.patch b/recipes/atd/files/no-oknodo.patch
new file mode 100644
index 0000000000..e1eb2528ac
--- /dev/null
+++ b/recipes/atd/files/no-oknodo.patch
@@ -0,0 +1,11 @@
+--- atd/dist/etc/init.d/atd.orig 2003-01-24 07:09:03.000000000 -0800
++++ atd/dist/etc/init.d/atd 2005-09-22 14:50:55.000000000 -0700
+@@ -16,7 +16,7 @@ case "$1" in
+ ;;
+ stop)
+ echo -n "Stopping at daemon: atd"
+- start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/atd.pid --exec /usr/sbin/atd
++ start-stop-daemon --stop --quiet --pidfile /var/run/atd.pid --exec /usr/sbin/atd
+ rm -f /var/spool/at/trigger
+ echo "."
+ ;;