aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch')
-rw-r--r--recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
new file mode 100644
index 0000000000..d8b3692efa
--- /dev/null
+++ b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -0,0 +1,30 @@
+--- autofs-4.1.4/Makefile.rules.orig 2006-04-06 16:47:33.000000000 -0500
++++ autofs-4.1.4/Makefile.rules 2006-04-06 16:49:16.000000000 -0500
+@@ -18,19 +18,19 @@
+ # The STRIP defined here *must not* remove any dynamic-loading symbols
+
+ ifdef DEBUG
+-CFLAGS = -O2 -g -DDEBUG
+-LDFLAGS = -g
++CFLAGS += -O2 -g -DDEBUG
++LDFLAGS += -g
+ STRIP = :
+ else
+-CFLAGS = -O3 -fomit-frame-pointer -Wall
+-LDFLAGS = -s
+-STRIP = strip --strip-debug
++CFLAGS += -O3 -fomit-frame-pointer -Wall
++LDFLAGS += -s
++STRIP = ${TARGET_PREFIX}strip --strip-debug
+ endif
+
+-CC = gcc
+-CXX = g++
++CC ?= ${TARGET_PREFIX}gcc
++CXX ?= ${TARGET_PREFIX}g++
+ CXXFLAGS = $(CFLAGS)
+-LD = ld
++LD ?= ${TARGET_PREFIX}ld
+ SOLDFLAGS = -shared -Xlinker -rpath -Xlinker $(autofslibdir)
+
+ # Standard rules