aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/autofs')
-rw-r--r--recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch8
-rw-r--r--recipes/autofs/autofs_4.1.4.bb6
2 files changed, 8 insertions, 6 deletions
diff --git a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
index d8b3692efa..dd54dc187a 100644
--- a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
+++ b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -6,15 +6,15 @@
ifdef DEBUG
-CFLAGS = -O2 -g -DDEBUG
-LDFLAGS = -g
-+CFLAGS += -O2 -g -DDEBUG
-+LDFLAGS += -g
++CFLAGS ?= -O2 -g -DDEBUG
++LDFLAGS ?= -g
STRIP = :
else
-CFLAGS = -O3 -fomit-frame-pointer -Wall
-LDFLAGS = -s
-STRIP = strip --strip-debug
-+CFLAGS += -O3 -fomit-frame-pointer -Wall
-+LDFLAGS += -s
++CFLAGS ?= -O3 -fomit-frame-pointer -Wall
++LDFLAGS ?= -s
+STRIP = ${TARGET_PREFIX}strip --strip-debug
endif
diff --git a/recipes/autofs/autofs_4.1.4.bb b/recipes/autofs/autofs_4.1.4.bb
index d9863ad9dd..2f998ab220 100644
--- a/recipes/autofs/autofs_4.1.4.bb
+++ b/recipes/autofs/autofs_4.1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Kernel based automounter for linux."
SECTION = "base"
LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
@@ -20,7 +20,9 @@ inherit autotools update-rc.d
INITSCRIPT_NAME = "autofs"
INITSCRIPT_PARAMS = "defaults"
-EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
+# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
+CFLAGS += "${LDFLAGS}"
+EXTRA_OEMAKE = "STRIP=/bin/true"
PARALLEL_MAKE = ""
do_configure_prepend () {