aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/balsa
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/balsa')
-rw-r--r--recipes/balsa/balsa-2.0.17/desktop-file-fix.patch8
-rw-r--r--recipes/balsa/balsa-2.0.17/libmutt-cross.patch20
-rw-r--r--recipes/balsa/balsa_2.0.17.bb24
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes/balsa/balsa-2.0.17/desktop-file-fix.patch b/recipes/balsa/balsa-2.0.17/desktop-file-fix.patch
new file mode 100644
index 0000000000..1f169eea8b
--- /dev/null
+++ b/recipes/balsa/balsa-2.0.17/desktop-file-fix.patch
@@ -0,0 +1,8 @@
+--- balsa-2.0.17/balsa.desktop~ 2003-07-08 15:37:35.000000000 +0100
++++ balsa-2.0.17/balsa.desktop 2004-08-03 23:23:50.000000000 +0100
+@@ -80,4 +80,4 @@
+ Terminal=0
+ Type=Application
+ StartupNotify=true
+-Categories=GNOME;Application;Network
++Categories=GNOME;Application;Network;
diff --git a/recipes/balsa/balsa-2.0.17/libmutt-cross.patch b/recipes/balsa/balsa-2.0.17/libmutt-cross.patch
new file mode 100644
index 0000000000..983368528f
--- /dev/null
+++ b/recipes/balsa/balsa-2.0.17/libmutt-cross.patch
@@ -0,0 +1,20 @@
+--- balsa-2.0.17/libmutt/configure.in~ 2003-03-24 22:36:15.000000000 +0000
++++ balsa-2.0.17/libmutt/configure.in 2004-06-27 16:45:40.000000000 +0100
+@@ -131,7 +131,7 @@
+ if (s.st_mode & S_IWOTH) exit (0);
+ exit (1);
+ }], [mutt_cv_worldwrite=yes], [mutt_cv_worldwrite=no],
+- [ AC_MSG_ERROR("Cannot cross compile libmutt. Yet")] ))
++ [mutt_cv_worldwrite=no] ))
+
+ mutt_cv_setgid=no
+ if test $mutt_cv_worldwrite = yes; then
+@@ -149,7 +149,7 @@
+ if (s.st_mode & S_IWGRP) exit (0);
+ exit (1);
+ }], [mutt_cv_groupwrite=yes], [mutt_cv_groupwrite=no],
+- [ AC_MSG_ERROR("Cannot cross compile libmutt. Yet")] ))
++ [mutt_cv_worldwrite=no] ))
+
+ dnl if test $mutt_cv_groupwrite = yes; then
+ dnl AC_DEFINE(USE_DOTLOCK)
diff --git a/recipes/balsa/balsa_2.0.17.bb b/recipes/balsa/balsa_2.0.17.bb
new file mode 100644
index 0000000000..7418f648e5
--- /dev/null
+++ b/recipes/balsa/balsa_2.0.17.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Balsa is an e-mail client for GNOME, highly configurable and \
+incorporating all the features you would expect in a robust mail client."
+HOMEPAGE = "http://balsa.gnome.org"
+SECTION = "x11/network"
+LICENSE = "GPL"
+DEPENDS = "libesmtp glib-2.0 libgnome libgnomeui gtk+ gnome-vfs libbonobo aspell libpcre libtool openssl gtkhtml-3.0"
+RDEPENDS = "gdk-pixbuf-loader-xpm"
+PR = "r3"
+
+SRC_URI = "http://talinux.fi.tal.org/pub/talinux/sources/balsa-${PV}.tar.bz2 \
+ file://libmutt-cross.patch;patch=1 \
+ file://desktop-file-fix.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl"
+
+do_configure_prepend() {
+ # aclocal seems to insist on looking in here. Make sure it exists.
+ mkdir -p ${S}/m4
+ # work around automake lossage with AC_CONFIG_AUX_DIR
+ ( cd libmutt; libtoolize --force ; cp ../ltmain.sh . )
+}
+