aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/base-passwd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/base-passwd')
-rw-r--r--recipes/base-passwd/base-passwd_3.5.20.bb57
-rw-r--r--recipes/base-passwd/files/mysql.patch8
-rw-r--r--recipes/base-passwd/files/nobash.patch13
-rw-r--r--recipes/base-passwd/files/root-home.patch8
-rw-r--r--recipes/base-passwd/files/slugos/README14
-rw-r--r--recipes/base-passwd/files/slugos/root-home.patch8
6 files changed, 108 insertions, 0 deletions
diff --git a/recipes/base-passwd/base-passwd_3.5.20.bb b/recipes/base-passwd/base-passwd_3.5.20.bb
new file mode 100644
index 0000000000..78079a0aa6
--- /dev/null
+++ b/recipes/base-passwd/base-passwd_3.5.20.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "Base system password/group files."
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_${PV}.tar.gz \
+ file://nobash.patch;patch=1 \
+ file://root-home.patch;patch=1 \
+ file://mysql.patch;patch=1 \
+"
+S = "${WORKDIR}/base-passwd"
+
+inherit autotools
+
+do_install () {
+ install -d -m 755 ${D}${sbindir}
+ install -p -m 755 update-passwd ${D}${sbindir}/
+ install -d -m 755 \
+ ${D}${mandir}/man8 ${D}${mandir}/pl/man8
+ install -p -m 644 man/update-passwd.8 \
+ ${D}${mandir}/man8/
+ install -p -m 644 man/update-passwd.pl.8 \
+ ${D}${mandir}/pl/man8/update-passwd.8
+ gzip -9 ${D}${mandir}/man8/* \
+ ${D}${mandir}/pl/man8/*
+ install -d -m 755 ${D}${datadir}/base-passwd
+ install -p -m 644 passwd.master \
+ ${D}${datadir}/base-passwd/
+ install -p -m 644 group.master \
+ ${D}${datadir}/base-passwd/
+
+ install -d -m 755 ${D}${docdir}/${PN}
+ install -p -m 644 debian/changelog ${D}${docdir}/${PN}/
+ gzip -9 ${D}${docdir}/${PN}/*
+ install -p -m 644 README ${D}${docdir}/${PN}/
+ install -p -m 644 debian/copyright ${D}${docdir}/${PN}/
+}
+
+
+do_install_append_openmn() {
+ echo "0:Jn6tcg/qjqvUE:0:0:root:/root:/bin/sh" >>${D}${datadir}/base-passwd/passwd.master
+}
+
+FILES_${PN}-doc += "${docdir}"
+
+pkg_postinst () {
+ set -e
+
+ if [ ! -e $D${sysconfdir}/passwd ] ; then
+ cp $D${datadir}/base-passwd/passwd.master $D${sysconfdir}/passwd
+ fi
+
+ if [ ! -e $D${sysconfdir}/group ] ; then
+ cp $D${datadir}/base-passwd/group.master $D${sysconfdir}/group
+ fi
+ exit 0
+}
diff --git a/recipes/base-passwd/files/mysql.patch b/recipes/base-passwd/files/mysql.patch
new file mode 100644
index 0000000000..b641f41238
--- /dev/null
+++ b/recipes/base-passwd/files/mysql.patch
@@ -0,0 +1,8 @@
+--- base-passwd/group.master.orig 2005-07-08 06:36:07.717990112 +0200
++++ base-passwd/group.master 2005-07-08 06:36:32.000000000 +0200
+@@ -36,4 +36,5 @@
+ staff:*:50:
+ games:*:60:
+ users:*:100:
++mysql:*:64001:
+ nogroup:*:65534:
diff --git a/recipes/base-passwd/files/nobash.patch b/recipes/base-passwd/files/nobash.patch
new file mode 100644
index 0000000000..2bde9bf33b
--- /dev/null
+++ b/recipes/base-passwd/files/nobash.patch
@@ -0,0 +1,13 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- base-passwd/passwd.master~nobash
++++ base-passwd/passwd.master
+@@ -1,4 +1,4 @@
+-root::0:0:root:/root:/bin/bash
++root::0:0:root:/root:/bin/sh
+ daemon:*:1:1:daemon:/usr/sbin:/bin/sh
+ bin:*:2:2:bin:/bin:/bin/sh
+ sys:*:3:3:sys:/dev:/bin/sh
diff --git a/recipes/base-passwd/files/root-home.patch b/recipes/base-passwd/files/root-home.patch
new file mode 100644
index 0000000000..85d96b6185
--- /dev/null
+++ b/recipes/base-passwd/files/root-home.patch
@@ -0,0 +1,8 @@
+--- base-passwd/passwd.master.orig 2005-07-08 06:26:22.000000000 +0200
++++ base-passwd/passwd.master 2005-07-08 06:31:58.000000000 +0200
+@@ -1,4 +1,4 @@
+-root::0:0:root:/root:/bin/sh
++root::0:0:root:/home/root:/bin/sh
+ daemon:*:1:1:daemon:/usr/sbin:/bin/sh
+ bin:*:2:2:bin:/bin:/bin/sh
+ sys:*:3:3:sys:/dev:/bin/sh
diff --git a/recipes/base-passwd/files/slugos/README b/recipes/base-passwd/files/slugos/README
new file mode 100644
index 0000000000..1abe54b5a2
--- /dev/null
+++ b/recipes/base-passwd/files/slugos/README
@@ -0,0 +1,14 @@
+This patch overrides the root-home.patch for all DISTROs
+derived from slugos (DISTROs which set slugos in OVERRIDES)
+
+The patch sets a root password on /etc/passwd, this password is
+
+opeNSLUg
+
+This allows ssh (dropbear) login to an OpenSlug NSLU2 using that
+password.
+
+The password is NO MORE SECURE than the previous empty string,
+however, because ssh logins can now succeed the NSLU2 is LESS
+secure! This password must be changed as soon as possible after
+initial configuration of the NSLU2.
diff --git a/recipes/base-passwd/files/slugos/root-home.patch b/recipes/base-passwd/files/slugos/root-home.patch
new file mode 100644
index 0000000000..97dab68f33
--- /dev/null
+++ b/recipes/base-passwd/files/slugos/root-home.patch
@@ -0,0 +1,8 @@
+--- base-passwd/passwd.master.orig 2005-07-08 06:26:22.000000000 +0200
++++ base-passwd/passwd.master 2005-07-08 06:31:58.000000000 +0200
+@@ -1,4 +1,4 @@
+-root::0:0:root:/root:/bin/sh
++root:Xm./49bYkrkuo:0:0:root:/root:/bin/sh
+ daemon:*:1:1:daemon:/usr/sbin:/bin/sh
+ bin:*:2:2:bin:/bin:/bin/sh
+ sys:*:3:3:sys:/dev:/bin/sh