aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/batmand
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/batmand')
-rw-r--r--recipes/batmand/batmand-0.3.2/makefile-fix.patch13
-rw-r--r--recipes/batmand/batmand.inc28
-rw-r--r--recipes/batmand/batmand_0.3.2.bb3
-rw-r--r--recipes/batmand/batmand_0.3.bb30
4 files changed, 46 insertions, 28 deletions
diff --git a/recipes/batmand/batmand-0.3.2/makefile-fix.patch b/recipes/batmand/batmand-0.3.2/makefile-fix.patch
new file mode 100644
index 0000000000..9e74a91471
--- /dev/null
+++ b/recipes/batmand/batmand-0.3.2/makefile-fix.patch
@@ -0,0 +1,13 @@
+Index: batman-0.3.2/Makefile
+===================================================================
+--- batman-0.3.2.orig/Makefile 2009-05-15 21:41:16.000000000 +0200
++++ batman-0.3.2/Makefile 2009-09-22 16:20:05.937937168 +0200
+@@ -28,8 +28,6 @@
+ # activate this variable to deactivate policy routing for backward compatibility
+ #NO_POLICY_ROUTING = -DNO_POLICY_ROUTING
+
+-CC = gcc
+-CFLAGS += -pedantic -Wall -W -O1 -g3 -std=gnu99
+ EXTRA_CFLAGS = -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA $(NO_POLICY_ROUTING) -DREVISION_VERSION=$(REVISION_VERSION)
+ LDFLAGS += -lpthread
+
diff --git a/recipes/batmand/batmand.inc b/recipes/batmand/batmand.inc
new file mode 100644
index 0000000000..cb99cf0d74
--- /dev/null
+++ b/recipes/batmand/batmand.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.open-mesh.net/"
+
+INC_PR = "r1"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "http://downloads.open-mesh.net/batman/stable/sources/batman/batman-${PV}.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}
diff --git a/recipes/batmand/batmand_0.3.2.bb b/recipes/batmand/batmand_0.3.2.bb
new file mode 100644
index 0000000000..f359f5e7ca
--- /dev/null
+++ b/recipes/batmand/batmand_0.3.2.bb
@@ -0,0 +1,3 @@
+require batmand.inc
+PR = "${INC_PR}.1"
+
diff --git a/recipes/batmand/batmand_0.3.bb b/recipes/batmand/batmand_0.3.bb
index c78f94d5e3..f359f5e7ca 100644
--- a/recipes/batmand/batmand_0.3.bb
+++ b/recipes/batmand/batmand_0.3.bb
@@ -1,29 +1,3 @@
-DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "GPL"
-HOMEPAGE = "https://www.open-mesh.net/batman"
+require batmand.inc
+PR = "${INC_PR}.1"
-PR = "r0"
-
-RDEPENDS = "kernel-module-tun"
-
-SRC_URI = "\
- http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
- file://makefile-fix.patch;patch=1 \
- "
-
-S = "${WORKDIR}/batman-${PV}"
-
-do_compile() {
- oe_runmake
-}
-
-do_stage() {
- :
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 batmand ${D}${bindir}
-}