aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/batmand
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/batmand')
-rw-r--r--recipes/batmand/batmand_0.3.bb29
-rw-r--r--recipes/batmand/files/makefile-fix.patch13
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/batmand/batmand_0.3.bb b/recipes/batmand/batmand_0.3.bb
new file mode 100644
index 0000000000..c78f94d5e3
--- /dev/null
+++ b/recipes/batmand/batmand_0.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "https://www.open-mesh.net/batman"
+
+PR = "r0"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "\
+ http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}
diff --git a/recipes/batmand/files/makefile-fix.patch b/recipes/batmand/files/makefile-fix.patch
new file mode 100644
index 0000000000..ff6ceb38e1
--- /dev/null
+++ b/recipes/batmand/files/makefile-fix.patch
@@ -0,0 +1,13 @@
+Index: batman-0.3/Makefile
+===================================================================
+--- batman-0.3.orig/Makefile 2008-05-15 19:09:47.000000000 +0200
++++ batman-0.3/Makefile 2008-05-15 21:01:14.000000000 +0200
+@@ -17,8 +17,6 @@
+ #
+
+
+-CC = gcc
+-CFLAGS = -Wall -O1 -g3
+ EXTRA_CFLAGS = -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA -DREVISION_VERSION=$(REVISION_VERSION)
+ LDFLAGS = -lpthread
+