summaryrefslogtreecommitdiffstats
path: root/recipes/bc/bc_1.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bc/bc_1.06.bb')
-rw-r--r--recipes/bc/bc_1.06.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/bc/bc_1.06.bb b/recipes/bc/bc_1.06.bb
index d95fcad9f6..151ab1c27f 100644
--- a/recipes/bc/bc_1.06.bb
+++ b/recipes/bc/bc_1.06.bb
@@ -2,8 +2,22 @@ DESCRIPTION = "An arbitrary precision calculator language."
SECTION = "console/utils"
SRC_URI = "${GNU_MIRROR}/bc/bc-${PV}.tar.gz"
LICENSE = "GPL"
+PR = "r1"
inherit autotools
+do_install () {
+ autotools_do_install
+ mv ${D}${bindir}/dc ${D}${bindir}/dc.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/dc dc dc.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove dc dc.${PN}
+}
+
SRC_URI[md5sum] = "d44b5dddebd8a7a7309aea6c36fda117"
SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33"