aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/beecrypt/beecrypt_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/beecrypt/beecrypt_3.1.0.bb')
-rw-r--r--recipes/beecrypt/beecrypt_3.1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/beecrypt/beecrypt_3.1.0.bb b/recipes/beecrypt/beecrypt_3.1.0.bb
new file mode 100644
index 0000000000..f9a45e74df
--- /dev/null
+++ b/recipes/beecrypt/beecrypt_3.1.0.bb
@@ -0,0 +1,28 @@
+# Beecrypt OE build file
+# Copyright (C) 2004-2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Beecrypt is a general-purpose cryptography library."
+HOMEPAGE="http://sourceforge.net/projects/beecrypt"
+SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz"
+
+PR = "r2"
+
+inherit autotools
+acpaths=""
+
+EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
+
+do_stage() {
+
+# oe_libinstall -a -C .libs libbeecrypt ${STAGING_LIBDIR}
+ cp .libs/libbeecrypt.a ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}/beecrypt
+ for X in beecrypt.h beecrypt.api.h memchunk.h mpnumber.h beecrypt.gnu.h mp.h mpopt.h blockmode.h endianness.h
+ do
+ install -m 0644 ${X} ${STAGING_INCDIR}/beecrypt/${X}
+ done
+
+}
+