aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/beep/beep_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/beep/beep_1.2.2.bb')
-rw-r--r--recipes/beep/beep_1.2.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/beep/beep_1.2.2.bb b/recipes/beep/beep_1.2.2.bb
new file mode 100644
index 0000000000..759f74f8a0
--- /dev/null
+++ b/recipes/beep/beep_1.2.2.bb
@@ -0,0 +1,30 @@
+# beep: a console utility to "and allow a little more granularity
+# than you get with the default terminal bell"
+DESCRIPTION = "A console utility to make a beep noise"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r2"
+DEPENDS = "install-native"
+
+SRC_URI = "http://johnath.com/beep/beep-${PV}.tar.gz"
+SRC_URI += "file://linux-input.patch;patch=1"
+
+S = "${WORKDIR}/beep-${PV}"
+PACKAGES += "${PN} ${PN}-doc"
+
+inherit autotools
+
+EXTRA_OEMAKE += 'CC="${CC}"'
+EXTRA_OEMAKE += 'FLAGS="${CFLAGS}"'
+
+# slugos requires beep in boot
+BINDIR = "${bindir}"
+BINDIR_slugos = "${base_bindir}"
+
+do_install() {
+ # this is easier than patching the Makefile...
+ install -d "${D}${BINDIR}"
+ install -c -m 755 beep "${D}${BINDIR}/beep"
+ install -d "${D}${mandir}/man1"
+ install -c -m 644 beep.1.gz "${D}${mandir}/man1/beep.1.gz"
+}